summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/flask-socketio/flask-socketio-2.8.2.ebuild')
-rw-r--r--dev-python/flask-socketio/flask-socketio-2.8.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-socketio/flask-socketio-2.8.2.ebuild b/dev-python/flask-socketio/flask-socketio-2.8.2.ebuild
new file mode 100644
index 000000000000..62159d187544
--- /dev/null
+++ b/dev-python/flask-socketio/flask-socketio-2.8.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Flask-SocketIO"
+DESCRIPTION="Socket.IO integration for Flask applications."
+HOMEPAGE="https://flask-socketio.readthedocs.org/ https://github.com/miguelgrinberg/${MY_PN}/ https://pypi.python.org/pypi/${MY_PN}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ dev-python/python-socketio[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/coverage[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# pypi tarball does not contain tests
+RESTRICT="test"
+
+python_test() {
+ PYTHONPATH="${PWD}" python ./test_socketio.py || die
+}