summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyformance/pyformance-0.4.ebuild')
-rw-r--r--dev-python/pyformance/pyformance-0.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyformance/pyformance-0.4.ebuild b/dev-python/pyformance/pyformance-0.4.ebuild
new file mode 100644
index 000000000000..67ffb16e602c
--- /dev/null
+++ b/dev-python/pyformance/pyformance-0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Performance metrics, based on Coda Hale's Yammer metrics"
+HOMEPAGE="https://pyformance.readthedocs.org/ https://github.com/omergertel/pyformance/ https://pypi.org/project/pyformance/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+python_prepare() {
+ sed -i -e "s/find_packages()/find_packages(exclude=['tests'])/"
+}
+
+python_test() {
+ py.test || die
+}