summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygame/pygame-2.0.1-r1.ebuild')
-rw-r--r--dev-python/pygame/pygame-2.0.1-r1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/pygame/pygame-2.0.1-r1.ebuild b/dev-python/pygame/pygame-2.0.1-r1.ebuild
index 9fc9d5a9db70..b8c0c5f73b53 100644
--- a/dev-python/pygame/pygame-2.0.1-r1.ebuild
+++ b/dev-python/pygame/pygame-2.0.1-r1.ebuild
@@ -2,7 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -51,6 +52,10 @@ src_prepare() {
if ! use midi; then
rm test/midi_test.py || die
fi
+ # Fixed in next release
+ sed -e 's/++Py_REFCNT/Py_INCREF/' \
+ -e 's/--Py_REFCNT/Py_DECREF/' \
+ -i src_c/_sdl2/*.c || die
distutils-r1_src_prepare
}