summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pygments/pygments-2.11.0.ebuild')
-rw-r--r--dev-python/pygments/pygments-2.11.0.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/pygments/pygments-2.11.0.ebuild b/dev-python/pygments/pygments-2.11.0.ebuild
deleted file mode 100644
index 2deb8e14f9ae..000000000000
--- a/dev-python/pygments/pygments-2.11.0.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-inherit distutils-r1 bash-completion-r1
-
-MY_P=${P^}
-DESCRIPTION="Pygments is a syntax highlighting package written in Python"
-HOMEPAGE="
- https://pygments.org/
- https://github.com/pygments/pygments/
- https://pypi.org/project/Pygments/"
-SRC_URI="mirror://pypi/${MY_P:0:1}/${PN^}/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc"
-
-BDEPEND="
- test? (
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/wcag-contrast-ratio[${PYTHON_USEDEP}]
- virtual/ttf-fonts
- )"
-
-distutils_enable_sphinx doc \
- dev-python/wcag-contrast-ratio
-distutils_enable_tests pytest
-
-python_install_all() {
- distutils-r1_python_install_all
- newbashcomp external/pygments.bashcomp pygmentize
-}