summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/metadata.xml2
-rw-r--r--dev-python/pytest-env/pytest-env-0.8.1.ebuild8
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-python/pytest-env/metadata.xml b/dev-python/pytest-env/metadata.xml
index ccf6121fada8..49fee13e6537 100644
--- a/dev-python/pytest-env/metadata.xml
+++ b/dev-python/pytest-env/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
- <remote-id type="github">MobileDynasty/pytest-env</remote-id>
+ <remote-id type="github">pytest-dev/pytest-env</remote-id>
<remote-id type="pypi">pytest-env</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/pytest-env/pytest-env-0.8.1.ebuild b/dev-python/pytest-env/pytest-env-0.8.1.ebuild
index 3ab29754ad80..2c0cc5da7303 100644
--- a/dev-python/pytest-env/pytest-env-0.8.1.ebuild
+++ b/dev-python/pytest-env/pytest-env-0.8.1.ebuild
@@ -3,16 +3,20 @@
EAPI=8
-DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
DESCRIPTION="py.test plugin that allows you to add environment variables"
-HOMEPAGE="https://github.com/MobileDynasty/pytest-env"
+HOMEPAGE="https://github.com/pytest-dev/pytest-env"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="dev-python/hatch-vcs[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest