summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild')
-rw-r--r--dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild b/dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild
new file mode 100644
index 000000000000..9564d7976934
--- /dev/null
+++ b/dev-python/pytest-xdist/pytest-xdist-1.28.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed testing and loop-on-failing modes"
+HOMEPAGE="https://pypi.org/project/pytest-xdist/ https://github.com/pytest-dev/pytest-xdist"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/execnet[${PYTHON_USEDEP}]
+ >=dev-python/pytest-4.4[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/filelock[${PYTHON_USEDEP}] )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.28.0-strip-setuptools-scm.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+ pytest -vv testing || die "Tests failed under ${EPYTHON}"
+}