summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-dbusmock')
-rw-r--r--dev-python/python-dbusmock/Manifest2
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.33.0.ebuild54
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild53
-rw-r--r--dev-python/python-dbusmock/python-dbusmock-0.34.2.ebuild4
4 files changed, 2 insertions, 111 deletions
diff --git a/dev-python/python-dbusmock/Manifest b/dev-python/python-dbusmock/Manifest
index ee37365d25df..f97fdc1f7d38 100644
--- a/dev-python/python-dbusmock/Manifest
+++ b/dev-python/python-dbusmock/Manifest
@@ -1,3 +1 @@
-DIST python-dbusmock-0.33.0.tar.gz 105903 BLAKE2B 5a101e64d5eff70e7a32d21080cd0051fd5617c8d057fe1cbe465903eda419fab9d0e720b0c72bac2c856d9a1371493c9b01d07ec144c2a847b6c44b65f6dd3c SHA512 419f09a5bfeab4e914c809546f3dc3bd294844116f7f0cd4a6a0b4121493c64fe6587647866323f74ed2818d1d6b45d417e384ea54c6d1244233b2a7b0d8d97d
-DIST python_dbusmock-0.34.1.tar.gz 111561 BLAKE2B 933b09ea2a679831894432bcd2e74804c3b8e7023d924512eccfdab40165f99736f85a27dd98accc2d97e36e546729fff4954eb913f7d3f5293aa50ba9326620 SHA512 093b5dec4b6f9d70b480046320211beca02e83cd0bc077448bb5329d888634805e4e6dfac9d1665b4c1ee5a15c1cec613a530443954cb4676b7a025c52bf457f
DIST python_dbusmock-0.34.2.tar.gz 111535 BLAKE2B 8f3f125bcfbf0d1674e0dea3d87d6f776e85fb818c5fd3f814ca139f4f6936e06eabe7c60c467114918609e1897b0c770a5765eb356fc1843eb781e264fd93ac SHA512 3a4a46afa0ca54004a6891c639c0e1bfd879e575189bdd1bbe031f12333d2358af77456e8b6cb32681010b7c19fb8171f819f67ec8960494408100118b19881d
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.33.0.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.33.0.ebuild
deleted file mode 100644
index 1b12f148b5bb..000000000000
--- a/dev-python/python-dbusmock/python-dbusmock-0.33.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..13} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Easily create mock objects on D-Bus for software testing"
-HOMEPAGE="
- https://github.com/martinpitt/python-dbusmock/
- https://pypi.org/project/python-dbusmock/
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- sys-power/upower
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # linter tests, fragile to newer linter versions
- tests/test_code.py
-)
-
-src_prepare() {
- # dev-python/dbus-python uses autotools, so no .dist-info there
- sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # tests are fragile to long socket paths
- local -x TMPDIR=/tmp
- # Tests break if XDG_DATA_DIRS is modified by flatpak install
- unset XDG_DATA_DIRS
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild
deleted file mode 100644
index c61d864e5070..000000000000
--- a/dev-python/python-dbusmock/python-dbusmock-0.34.1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..13} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Easily create mock objects on D-Bus for software testing"
-HOMEPAGE="
- https://github.com/martinpitt/python-dbusmock/
- https://pypi.org/project/python-dbusmock/
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-RDEPEND="
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- sys-power/upower
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_IGNORE=(
- # linter tests, fragile to newer linter versions
- tests/test_code.py
-)
-
-src_prepare() {
- # dev-python/dbus-python uses autotools, so no .dist-info there
- sed -i '/dbus-python/d' pyproject.toml setup.cfg || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- # tests are fragile to long socket paths
- local -x TMPDIR=/tmp
- # Tests break if XDG_DATA_DIRS is modified by flatpak install
- unset XDG_DATA_DIRS
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
diff --git a/dev-python/python-dbusmock/python-dbusmock-0.34.2.ebuild b/dev-python/python-dbusmock/python-dbusmock-0.34.2.ebuild
index c61d864e5070..aa3afc2399e4 100644
--- a/dev-python/python-dbusmock/python-dbusmock-0.34.2.ebuild
+++ b/dev-python/python-dbusmock/python-dbusmock-0.34.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -17,7 +17,7 @@ HOMEPAGE="
LICENSE="LGPL-3+"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
dev-python/dbus-python[${PYTHON_USEDEP}]