summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-glanceclient/python-glanceclient-0.19.0-r1.ebuild')
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.19.0-r1.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.19.0-r1.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.19.0-r1.ebuild
deleted file mode 100644
index 623e7b63e4a2..000000000000
--- a/dev-python/python-glanceclient/python-glanceclient-0.19.0-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Glance API"
-HOMEPAGE="https://github.com/openstack/python-glanceclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-REQUIRED_USE="test? ( doc )"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hacking-0.10.0[${PYTHON_USEDEP}]
- <dev-python/hacking-0.11[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.36[${PYTHON_USEDEP}]
- !~dev-python/testtools-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
- >=dev-python/requests-mock-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/tempest-lib-0.5.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- )
- "
-RDEPEND="
- >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
- <dev-python/pbr-2.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-1.6.0[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.11[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
- >=dev-python/warlock-1.0.1[${PYTHON_USEDEP}]
- <dev-python/warlock-2[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
- sed -i '/^argparse/d' requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-python_test() {
- testr init
- testr run || die "testsuite failed under python2.7"
- flake8 tests && einfo "run flake8 over tests folder passed" || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}