summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ratelimit/ratelimit-1.4.1.ebuild')
-rw-r--r--dev-python/ratelimit/ratelimit-1.4.1.ebuild13
1 files changed, 3 insertions, 10 deletions
diff --git a/dev-python/ratelimit/ratelimit-1.4.1.ebuild b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
index bc4af83a74e6..6974189b99e6 100644
--- a/dev-python/ratelimit/ratelimit-1.4.1.ebuild
+++ b/dev-python/ratelimit/ratelimit-1.4.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit distutils-r1
@@ -13,18 +13,11 @@ HOMEPAGE="https://github.com/tomasbasham/ratelimit"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-DEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+distutils_enable_tests pytest
src_prepare() {
default
# remove --cov args injection
rm pytest.ini || die
}
-
-python_test() {
- pytest || die
-}