summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/rich-13.3.4.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/rich/rich-13.3.4.ebuild b/dev-python/rich/rich-13.3.4.ebuild
index 574f2f1e1b9d..d5ef23a1e852 100644
--- a/dev-python/rich/rich-13.3.4.ebuild
+++ b/dev-python/rich/rich-13.3.4.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 optfeature
@@ -44,6 +44,15 @@ python_test() {
tests/test_syntax.py::test_python_render_simple_indent_guides
tests/test_syntax.py::test_python_render_line_range_indent_guides
)
+ if [[ ${EPYTHON} == python3.12 ]]; then
+ EPYTEST_DESELECT+=(
+ # version-specific output -- the usual deal
+ tests/test_inspect.py::test_inspect_builtin_function_except_python311
+ tests/test_inspect.py::test_inspect_integer_with_methods_python310only
+ tests/test_inspect.py::test_inspect_integer_with_methods_python311_and_above
+ tests/test_pretty.py::test_attrs_broken
+ )
+ fi
epytest -p no:pytest-qt
}