summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild')
-rw-r--r--dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild b/dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild
new file mode 100644
index 000000000000..f1cc4de7e891
--- /dev/null
+++ b/dev-python/zxcvbn/zxcvbn-4.4.28-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A realistic password strength estimator"
+HOMEPAGE="
+ https://github.com/dwolfhub/zxcvbn-python/
+ https://pypi.org/project/zxcvbn/
+"
+SRC_URI="
+ https://github.com/dwolfhub/zxcvbn-python/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/zxcvbn-python-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest