summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild')
-rw-r--r--dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
index b36d83a54f2e..4124df047534 100644
--- a/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
+++ b/dev-ros/joint_state_publisher/joint_state_publisher-9999.ebuild
@@ -20,3 +20,8 @@ RDEPEND="${DEPEND}
"
DEPEND="${DEPEND}
test? ( dev-ros/rostest[${PYTHON_SINGLE_USEDEP}] )"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}