summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk/tclxml/files')
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3.1-test.patch46
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch12
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3.2-format-security.patch16
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3_configure.patch74
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3_include_path.patch12
5 files changed, 160 insertions, 0 deletions
diff --git a/dev-tcltk/tclxml/files/tclxml-3.1-test.patch b/dev-tcltk/tclxml/files/tclxml-3.1-test.patch
new file mode 100644
index 000000000000..f312f4c897a5
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3.1-test.patch
@@ -0,0 +1,46 @@
+diff -Naur tclxml-3.1.orig/Makefile.in tclxml-3.1/Makefile.in
+--- tclxml-3.1.orig/Makefile.in 2005-05-20 21:02:01.000000000 +0900
++++ tclxml-3.1/Makefile.in 2007-12-24 13:28:55.000000000 +0900
+@@ -267,7 +267,7 @@
+ # -testdir $(srcdir)/tea.tests
+
+ test: binaries libraries
+- (cd $(srcdir)/tests; $(bindir)/tclsh8.4 all.tcl)
++ (cd $(srcdir)/tests; $(bindir)/tclsh all.tcl)
+
+ shell: binaries libraries
+ @$(TCLSH) $(SCRIPT)
+diff -Naur tclxml-3.1.orig/examples/README tclxml-3.1/examples/README
+--- tclxml-3.1.orig/examples/README 2000-12-28 15:07:12.000000000 +0900
++++ tclxml-3.1/examples/README 2007-12-24 13:29:21.000000000 +0900
+@@ -31,7 +31,7 @@
+ REC-xml-20001006.xml
+ The W3C XML spec in XML format. A handy file to run xmlwc over
+ to test your build. You should get this output with the command
+- tclsh8.3 xmlwc REC-xml-20001006.xml
++ tclsh xmlwc REC-xml-20001006.xml
+ :
+
+ 2929 14978 116827 REC-xml-20001006.xml
+diff -Naur tclxml-3.1.orig/examples/flatten.tcl tclxml-3.1/examples/flatten.tcl
+--- tclxml-3.1.orig/examples/flatten.tcl 2000-05-20 08:56:20.000000000 +0900
++++ tclxml-3.1/examples/flatten.tcl 2007-12-24 13:29:29.000000000 +0900
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # -*- tcl -*- \
+-exec tclsh8.3 "$0" "$@"
++exec tclsh "$0" "$@"
+
+ # flatten.tcl --
+ #
+diff -Naur tclxml-3.1.orig/examples/xmlwc tclxml-3.1/examples/xmlwc
+--- tclxml-3.1.orig/examples/xmlwc 2000-12-28 14:53:38.000000000 +0900
++++ tclxml-3.1/examples/xmlwc 2007-12-24 13:29:09.000000000 +0900
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # \
+-exec tclsh8.3 "$0" "$@"
++exec tclsh "$0" "$@"
+
+ package require xml
+
diff --git a/dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch b/dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch
new file mode 100644
index 000000000000..b463306abf1e
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3.2-fix-implicit-declarations.patch
@@ -0,0 +1,12 @@
+diff -urpN tclxml-3.2.orig/tclxml.c tclxml-3.2/tclxml.c
+--- tclxml-3.2.orig/tclxml.c 2009-06-08 12:56:10.000000000 +0200
++++ tclxml-3.2/tclxml.c 2009-06-08 12:57:24.000000000 +0200
+@@ -20,6 +20,8 @@
+ #include <tclxslt/tclxslt.h>
+ #include <string.h>
+
++int Tcldom_libxml2_Init ( Tcl_Interp *interp );
++
+ #define TCL_DOES_STUBS \
+ (TCL_MAJOR_VERSION > 8 || TCL_MAJOR_VERSION == 8 && (TCL_MINOR_VERSION > 1 || \
+ (TCL_MINOR_VERSION == 1 && TCL_RELEASE_LEVEL == TCL_FINAL_RELEASE)))
diff --git a/dev-tcltk/tclxml/files/tclxml-3.2-format-security.patch b/dev-tcltk/tclxml/files/tclxml-3.2-format-security.patch
new file mode 100644
index 000000000000..2d13c6575ea6
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3.2-format-security.patch
@@ -0,0 +1,16 @@
+ tclxslt-libxslt.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tclxslt-libxslt.c b/tclxslt-libxslt.c
+index d943bf7..d18f645 100644
+--- a/tclxslt-libxslt.c
++++ b/tclxslt-libxslt.c
+@@ -1506,7 +1506,7 @@ TclXSLTExtFunction(xpathCtxt, nargs)
+ obj = TclXSLT_ConvertTclObjToXPathObj(extinfo->interp, resultPtr);
+ valuePush(xpathCtxt, obj);
+ } else {
+- xmlGenericError(xmlGenericErrorContext,
++ xmlGenericError(xmlGenericErrorContext, "%s",
+ Tcl_GetStringFromObj(resultPtr, NULL));
+ /* Need to define a new error code - this is the closest in meaning */
+ xpathCtxt->error = XPATH_UNKNOWN_FUNC_ERROR;
diff --git a/dev-tcltk/tclxml/files/tclxml-3_configure.patch b/dev-tcltk/tclxml/files/tclxml-3_configure.patch
new file mode 100644
index 000000000000..58de6b1db4a8
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3_configure.patch
@@ -0,0 +1,74 @@
+Tkanhs to Matteo Pillon <matteo.pillon@gmail.com>
+--- tcl.m4 2006-02-24 21:04:37.000000000 +0100
++++ tcl.m4.1 2006-02-24 21:04:54.000000000 +0100
+@@ -588,7 +588,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++ system=MP-RAS-`awk '{print $3}' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+@@ -1454,7 +1454,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++ system=MP-RAS-`awk '{print $3}' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+--- configure 2004-07-11 05:43:18.000000000 +0200
++++ configure.1 2006-02-24 21:14:04.000000000 +0100
+@@ -3771,7 +3771,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
++ system=MP-RAS-`awk '{print }' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+--- tclconfig/tcl.m4 2003-12-03 21:06:35.000000000 +0100
++++ tclconfig/tcl.m4.1 2006-02-24 21:16:04.000000000 +0100
+@@ -759,7 +759,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++ system=MP-RAS-`awk '{print $3}' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+@@ -2026,7 +2026,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++ system=MP-RAS-`awk '{print $3}' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+--- expat/configure 2004-07-11 05:43:29.000000000 +0200
++++ expat/configure.1 2006-02-24 21:16:31.000000000 +0100
+@@ -3860,7 +3860,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
++ system=MP-RAS-`awk '{print }' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
+--- libxml2/configure 2004-07-11 14:11:03.000000000 +0200
++++ libxml2/configure.1 2006-02-24 21:16:50.000000000 +0100
+@@ -3912,7 +3912,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print }' /etc/.relid'`
++ system=MP-RAS-`awk '{print }' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`
diff --git a/dev-tcltk/tclxml/files/tclxml-3_include_path.patch b/dev-tcltk/tclxml/files/tclxml-3_include_path.patch
new file mode 100644
index 000000000000..c270d5762986
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3_include_path.patch
@@ -0,0 +1,12 @@
+--- expat/Makefile.in.orig 2006-04-08 12:28:11.594940750 +0200
++++ expat/Makefile.in 2006-04-08 12:28:26.927899000 +0200
+@@ -175,7 +175,8 @@
+ INCLUDES = @TCL_INCLUDES@ \
+ -I$(srcdir)/xmltok \
+ -I$(srcdir)/xmlparse \
+- -I$(srcdir)/xmlwf
++ -I$(srcdir)/xmlwf \
++ -I../include
+
+ EXTRA_CFLAGS = $(MEM_DEBUG_FLAGS) @EXTRA_CFLAGS@
+