summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tdom/files/tdom-0.9.1-useCC.patch28
-rw-r--r--dev-tcltk/tdom/tdom-0.9.1.ebuild2
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-tcltk/tdom/files/tdom-0.9.1-useCC.patch b/dev-tcltk/tdom/files/tdom-0.9.1-useCC.patch
new file mode 100644
index 000000000000..918c944b6f69
--- /dev/null
+++ b/dev-tcltk/tdom/files/tdom-0.9.1-useCC.patch
@@ -0,0 +1,28 @@
+--- a/tclconfig/tcl.m4 2019-12-07 22:00:18.094712146 +0100
++++ b/tclconfig/tcl.m4 2019-12-07 22:00:28.961515544 +0100
+@@ -434,7 +434,6 @@
+ AC_SUBST(TCL_STUB_LIB_SPEC)
+
+ AC_MSG_CHECKING([platform])
+- hold_cc=$CC; CC="$TCL_CC"
+ AC_TRY_COMPILE(,[
+ #ifdef _WIN32
+ #error win32
+@@ -446,7 +445,6 @@
+ TEA_PLATFORM="windows"
+ AC_CHECK_PROG(CYGPATH, cygpath, cygpath -m, echo) ]
+ )
+- CC=$hold_cc
+ AC_MSG_RESULT($TEA_PLATFORM)
+
+ # The BUILD_$pkg is to define the correct extern storage class
+--- a/configure.in 2019-12-07 22:06:56.954496437 +0100
++++ b/configure.in 2019-12-07 22:07:53.538472872 +0100
+@@ -33,6 +33,7 @@
+ TEA_INIT([3.13])
+
+ AC_CONFIG_AUX_DIR(tclconfig)
++AC_CONFIG_SUBDIRS([extensions/tnc extensions/example])
+
+ #--------------------------------------------------------------------
+ # Load the tclConfig.sh file
diff --git a/dev-tcltk/tdom/tdom-0.9.1.ebuild b/dev-tcltk/tdom/tdom-0.9.1.ebuild
index 4f20b7f47608..67ca7a61e0a4 100644
--- a/dev-tcltk/tdom/tdom-0.9.1.ebuild
+++ b/dev-tcltk/tdom/tdom-0.9.1.ebuild
@@ -21,6 +21,8 @@ DEPEND="
dev-libs/expat"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-useCC.patch )
+
src_prepare() {
append-libs -lm
sed \