summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccmalloc')
-rw-r--r--dev-util/ccmalloc/Manifest1
-rw-r--r--dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild39
-rw-r--r--dev-util/ccmalloc/metadata.xml15
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/ccmalloc/Manifest b/dev-util/ccmalloc/Manifest
new file mode 100644
index 000000000000..d0aca833eab2
--- /dev/null
+++ b/dev-util/ccmalloc/Manifest
@@ -0,0 +1 @@
+DIST ccmalloc-0.4.0.tar.gz 57917 SHA256 b4953cf8c2f4477ec2a5e8884308393826793df072aeef9edf2bac8d24a33bd3 SHA512 927389c08da02d4c67bbdb5121fba30d1f16e20f682ce67fdc350bc0446b058ccf92915c0c969a0055898fef3cd56de73ab0384c4e2e9af4d0faf3ab1af15086 WHIRLPOOL 0ab3c0c98d921fe7a8ae31e1c1af143b796c7d6674fda7cd1cf5e526acd4977f9ead8ded50f1c916d350b25e7677fd89c0418b30ecdf65778b241fc36691b7ad
diff --git a/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild b/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild
new file mode 100644
index 000000000000..528afbffa4f3
--- /dev/null
+++ b/dev-util/ccmalloc/ccmalloc-0.4.0-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="A easy-to-use memory debugging library"
+HOMEPAGE="http://www.inf.ethz.ch/personal/biere/projects/ccmalloc/"
+SRC_URI="http://www.inf.ethz.ch/personal/biere/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS #240274
+ sed -i \
+ -e "s/CFLAGS=/CFLAGS+=/" \
+ Makefile.in || die "sed in Makefile.in failed"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use debug && myconf="${myconf} --debug"
+ # Not a standard configure script.
+ ./configure --prefix=/usr ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}"/usr install || die "emake install failed"
+ dodoc BUGS FEATURES NEWS README TODO USAGE VERSION || die "dodoc failed"
+}
diff --git a/dev-util/ccmalloc/metadata.xml b/dev-util/ccmalloc/metadata.xml
new file mode 100644
index 000000000000..4514939928da
--- /dev/null
+++ b/dev-util/ccmalloc/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ If you want to remove memory leaks from your C or C++ programs or you
+ experience strange bugs, probably due to pointer access to freed data,
+ then ccmalloc may be the right tool for you. In general it can help you
+ to track down memory related problems with C and C++ programs. It does
+ not replace more sophistacted tools such as purify or valgrind, since it
+ can not detect illegal memory reads, at least not all type of memory reads.
+ </longdescription>
+</pkgmetadata>