summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/kup')
-rw-r--r--dev-util/kup/kup-0.3.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/kup/kup-0.3.4-r1.ebuild b/dev-util/kup/kup-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..b4681218e06f
--- /dev/null
+++ b/dev-util/kup/kup-0.3.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="kernel.org uploader tool"
+HOMEPAGE="https://www.kernel.org/pub/software/network/kup"
+SRC_URI="mirror://kernel/software/network/kup/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/BSD-Resource
+ dev-perl/Config-Simple
+"
+
+DOCS=( README )
+
+src_install() {
+ dobin "${PN}" "${PN}-server" gpg-sign-all
+ doman "${PN}.1"
+ einstalldocs
+}