summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gconf-editor')
-rw-r--r--gnome-extra/gconf-editor/Manifest1
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch34
-rw-r--r--gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch66
-rw-r--r--gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild40
-rw-r--r--gnome-extra/gconf-editor/metadata.xml5
5 files changed, 146 insertions, 0 deletions
diff --git a/gnome-extra/gconf-editor/Manifest b/gnome-extra/gconf-editor/Manifest
new file mode 100644
index 000000000000..83e92e3913d7
--- /dev/null
+++ b/gnome-extra/gconf-editor/Manifest
@@ -0,0 +1 @@
+DIST gconf-editor-3.0.1.tar.xz 1452468 SHA256 3064e84967b4b4216f5c7e065cfec8c52019438a590e9ed81366af2770660944 SHA512 faaf237233d94730902d7c8e231545841862451f5998ef06bc3d51f6cdf0bc16bd1cecfc6b6a9e0ccc5197a06bb4f89068bfb478f900f3272ba03a2d94ec2f49 WHIRLPOOL 991a5b7d6b02b3472a9207bb5750d18552ba5da15570f7f884950b838177431a42b1ebb0131bbf3f76abe8f6098a2af88e542ec88d22135f9c8684da0543703f
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch
new file mode 100644
index 000000000000..b7df8f51007d
--- /dev/null
+++ b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-assertion-crash.patch
@@ -0,0 +1,34 @@
+From 25d823099337f7ede4782f46fea46f251646dc3e Mon Sep 17 00:00:00 2001
+From: Edward Sheldrake <ejsheldrake@gmail.com>
+Date: Wed, 11 Apr 2012 07:27:16 +0000
+Subject: Fix assertion failed crash
+
+Fix "assertion failed: (last_slash != NULL)" crash while navigating the
+left tree view, fixed by having the model for the right list view emit
+all the row deleted signals before deleting any of its data.
+
+Fixes https://bugzilla.gnome.org/show_bug.cgi?id=670586
+---
+diff --git a/src/gconf-list-model.c b/src/gconf-list-model.c
+index 27e1af6..4fc60f8 100644
+--- a/src/gconf-list-model.c
++++ b/src/gconf-list-model.c
+@@ -133,11 +133,14 @@ gconf_list_model_set_root_path (GConfListModel *model, const gchar *root_path)
+
+ if (model->root_path != NULL) {
+ for (list = model->values; list; list = list->next) {
++ model->stamp++;
++ gtk_tree_model_row_deleted (GTK_TREE_MODEL (model), path);
++ }
++
++ for (list = model->values; list; list = list->next) {
+ GConfEntry *entry = list->data;
+
+ g_hash_table_remove (model->key_hash, gconf_entry_get_key (entry));
+- model->stamp++;
+- gtk_tree_model_row_deleted (GTK_TREE_MODEL (model), path);
+
+ gconf_entry_unref (entry);
+ }
+--
+cgit v0.9.2
diff --git a/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch
new file mode 100644
index 000000000000..0d79ec56c396
--- /dev/null
+++ b/gnome-extra/gconf-editor/files/gconf-editor-3.0.1-drop-accel.patch
@@ -0,0 +1,66 @@
+From 62e68d8e2f6e2c473820113fbf46ced9f77111d4 Mon Sep 17 00:00:00 2001
+From: William Jon McCann <jmccann@redhat.com>
+Date: Thu, 03 May 2012 18:10:53 +0000
+Subject: Drop use GTK accel maps
+
+They are confusing, weird, and stored in an obsolete location.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=675392
+---
+diff --git a/src/main.c b/src/main.c
+index 8da5ccc..9bce4b8 100644
+--- a/src/main.c
++++ b/src/main.c
+@@ -26,34 +26,6 @@
+ #include "gconf-stock-icons.h"
+ #include "gconf-editor-window.h"
+
+-static char *
+-build_accel_filename (void)
+-{
+- return g_build_filename (g_get_home_dir (), ".gnome2", "accels", PACKAGE, NULL);
+-}
+-
+-static void
+-load_accel_map (void)
+-{
+- char *map;
+-
+- map = build_accel_filename ();
+- gtk_accel_map_load (map);
+-
+- g_free (map);
+-}
+-
+-static void
+-save_accel_map (void)
+-{
+- char *map;
+-
+- map = build_accel_filename ();
+- gtk_accel_map_save (map);
+-
+- g_free (map);
+-}
+-
+ gint
+ main (gint argc, gchar **argv)
+ {
+@@ -92,7 +64,6 @@ main (gint argc, gchar **argv)
+ /* Register our stock icons */
+ gtk_icon_theme_append_search_path (gtk_icon_theme_get_default (), ICONDIR);
+ gconf_stock_icons_register ();
+- load_accel_map ();
+
+ gtk_window_set_default_icon_name ("gconf-editor");
+
+@@ -107,7 +78,6 @@ main (gint argc, gchar **argv)
+
+ gtk_main ();
+
+- save_accel_map ();
+ g_strfreev (remaining_args);
+
+ return 0;
+--
+cgit v0.9.2
diff --git a/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
new file mode 100644
index 000000000000..8d963804eaf5
--- /dev/null
+++ b/gnome-extra/gconf-editor/gconf-editor-3.0.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GCONF_DEBUG="no"
+
+inherit eutils gnome2
+
+DESCRIPTION="An editor to the GNOME config system"
+HOMEPAGE="https://git.gnome.org/browse/gconf-editor"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=x11-libs/gtk+-3.0.0:3
+ >=gnome-base/gconf-2.12:2
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ sys-devel/gettext
+ app-text/gnome-doc-utils
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ ~app-text/docbook-xml-dtd-4.1.2
+"
+# gnome-common for eautoreconf
+
+src_prepare() {
+ # Fix assertion failed crash (from 'master')
+ epatch "${FILESDIR}/${PN}-3.0.1-assertion-crash.patch"
+
+ # Drop use GTK accel maps (from 'master')
+ epatch "${FILESDIR}/${PN}-3.0.1-drop-accel.patch"
+
+ gnome2_src_prepare
+}
diff --git a/gnome-extra/gconf-editor/metadata.xml b/gnome-extra/gconf-editor/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/gnome-extra/gconf-editor/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>