summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/gucharmap/gucharmap-3.12.1.ebuild')
-rw-r--r--gnome-extra/gucharmap/gucharmap-3.12.1.ebuild62
1 files changed, 0 insertions, 62 deletions
diff --git a/gnome-extra/gucharmap/gucharmap-3.12.1.ebuild b/gnome-extra/gucharmap/gucharmap-3.12.1.ebuild
deleted file mode 100644
index 80127b9e7d53..000000000000
--- a/gnome-extra/gucharmap/gucharmap-3.12.1.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="yes"
-VALA_MIN_API_VERSION="0.16"
-VALA_USE_DEPEND="vapigen"
-
-inherit gnome2 vala
-
-DESCRIPTION="Unicode character map viewer and library"
-HOMEPAGE="https://live.gnome.org/Gucharmap"
-
-LICENSE="GPL-3"
-SLOT="2.90"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
-IUSE="cjk +introspection test vala"
-REQUIRED_USE="vala? ( introspection )"
-
-COMMON_DEPEND="
- >=dev-libs/glib-2.32:2
- >=x11-libs/pango-1.2.1[introspection?]
- >=x11-libs/gtk+-3.4.0:3[introspection?]
-
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
-"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-extra/gucharmap-3:0
-"
-DEPEND="${RDEPEND}
- app-text/yelp-tools
- dev-util/desktop-file-utils
- >=dev-util/gtk-doc-am-1
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
- test? ( app-text/docbook-xml-dtd:4.1.2 )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- # prevent file collisions with slot 0
- sed -e "s:GETTEXT_PACKAGE=gucharmap$:GETTEXT_PACKAGE=gucharmap-${SLOT}:" \
- -i configure.ac configure || die "sed configure.ac configure failed"
-
- # avoid autoreconf
- sed -e 's/-Wall //g' -i configure || die "sed failed"
-
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- # Do not add ITSTOOL=$(type -P true); yelp-tools is a true required
- # dependency here for some LINGUAS.
- gnome2_src_configure \
- --disable-static \
- $(use_enable introspection) \
- $(use_enable cjk unihan) \
- $(use_enable vala)
-}