summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/fotoxx')
-rw-r--r--media-gfx/fotoxx/Manifest1
-rw-r--r--media-gfx/fotoxx/fotoxx-22.11.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/media-gfx/fotoxx/Manifest b/media-gfx/fotoxx/Manifest
index fc17819462da..72f641fb6e5a 100644
--- a/media-gfx/fotoxx/Manifest
+++ b/media-gfx/fotoxx/Manifest
@@ -1,2 +1,3 @@
DIST fotoxx-21.60.tar.gz 8679841 BLAKE2B ec3dcbd0b937d730692e225fec7530ac46390328ae960e8960df7d252bc0cd8630de84bf47dfaf74c1e07855b4b0959e596e5e515ea00a6c430872359b2b4576 SHA512 ac999fcc70acd92c54e85ad276112aaa7f1b7606ea70381d6f833d829fd92c14aacad7a967838e5d28fce80cfa6da8ef05e0ee49b463210cb66a3f8ffc3d22e7
DIST fotoxx-22.1.tar.gz 8801382 BLAKE2B 9090d2ea0ddfcb91758fbe0b8c6b81fd3c764eef1cac8098c5ae5f4dba37b5426bc4d5dee6b7d36519f62b28bee7f3f45aa29a7c6f92209f193a5a5f0775ae7b SHA512 41335113cd37490d02112760845b6e0bc631c448a0bdfe0435082836c86a1e125fbbe8a0efd30aae4ec7e86f43a67c9b6697e47263424e5093c7a475450ee7bc
+DIST fotoxx-22.11.tar.gz 8836130 BLAKE2B bb2c769a1f4840a026632c8d5aa27e49a78636c99924b41d2ddaa865f1bfe72ec0cbcee4d43a2a6b091ec7c279ca73dfb91bac672ad6fcc691a7d118169f7dc7 SHA512 666afc3fd3bb1015e45af4902fa11dce51f647b7398441ad620df228be110f558308e3629f597825ebd0e998ad7b7b66e5e0ac1d4e7648ffdef7c42e61531c9f
diff --git a/media-gfx/fotoxx/fotoxx-22.11.ebuild b/media-gfx/fotoxx/fotoxx-22.11.ebuild
new file mode 100644
index 000000000000..852e25423552
--- /dev/null
+++ b/media-gfx/fotoxx/fotoxx-22.11.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature xdg-utils
+
+DESCRIPTION="Program for improving image files made with a digital camera"
+HOMEPAGE="https://kornelix.net/fotoxx/fotoxx.html"
+SRC_URI="https://kornelix.net/downloads/downloads/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+# For required dependencies read doc/README, for required tools read
+# data/userguide [INSTALLATION]. xdg-open (x11-misc/xdg-utils) is an
+# alternative to firefox and chromium-browser. `grep '"which ' * -R`
+# is helpful to report some required tools run via the shell.
+
+DEPEND="
+ media-libs/clutter
+ media-libs/clutter-gtk
+ media-libs/lcms:2
+ media-libs/libpng:0
+ media-libs/tiff:0
+ media-libs/libchamplain[gtk]
+ virtual/jpeg
+ x11-libs/gtk+:3"
+RDEPEND="
+ ${DEPEND}
+ media-gfx/dcraw
+ media-libs/exiftool
+ x11-misc/xdg-utils
+"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-21.40-documentation.patch" )
+
+DOCS=()
+HTML_DOCS=()
+
+src_prepare() {
+ sed -i -e "/^DOCDIR/ s/${PN}$/${PF}/" Makefile || die
+ default
+}
+
+src_install() {
+ # For the Help menu items to work, *.html must be in /usr/share/doc/${PF},
+ # and README, changelog, copyright, license, etc. must not be compressed.
+ emake DESTDIR="${D}" install
+ rm -f "${D}"/usr/share/doc/${PF}/*.man || die
+ docompress -x /usr/share/doc
+}
+
+pkg_postinst() {
+ optfeature "HEIC file support" media-libs/libheif
+ optfeature "additional RAW file support" media-gfx/rawtherapee
+ optfeature "additional RAW file support" media-gfx/darktable
+ optfeature "video thumbnails & playback" media-video/ffmpeg
+ optfeature "copying images to optical media" app-cdr/dvd+rw-tools
+ optfeature "additional panorama support" media-gfx/hugin
+ optfeature "WEBP file support" media-libs/libwebp
+
+ elog
+ elog "Please read the Help > User Guide for details. The source location is"
+ elog "/usr/share/fotoxx/data/userguide and after running fotoxx a copy will"
+ elog "be placed at /home/<user>/.fotoxx/userguide."
+ elog
+ elog "To play videos, in Tools > Preferences set 'Video File Play Command'."
+ elog
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}