summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/codec2/codec2-0.9.2-r1.ebuild')
-rw-r--r--media-libs/codec2/codec2-0.9.2-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/media-libs/codec2/codec2-0.9.2-r1.ebuild b/media-libs/codec2/codec2-0.9.2-r1.ebuild
new file mode 100644
index 000000000000..ca1c0954f6c5
--- /dev/null
+++ b/media-libs/codec2/codec2-0.9.2-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ http://www.rowetel.com/?page_id=452"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNITTEST=OFF
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+ cmake_src_configure
+}