summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/mplayer/mplayer-9999.ebuild')
-rw-r--r--media-video/mplayer/mplayer-9999.ebuild23
1 files changed, 16 insertions, 7 deletions
diff --git a/media-video/mplayer/mplayer-9999.ebuild b/media-video/mplayer/mplayer-9999.ebuild
index 8abf788096fd..59ad25c596aa 100644
--- a/media-video/mplayer/mplayer-9999.ebuild
+++ b/media-video/mplayer/mplayer-9999.ebuild
@@ -36,12 +36,15 @@ SRC_URI="
!truetype? ( ${FONT_URI} )
"
-IUSE="cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_fma3 cpu_flags_x86_fma4"
+IUSE="cpu_flags_x86_avx cpu_flags_x86_avx2"
+IUSE+=" cpu_flags_x86_fma3 cpu_flags_x86_fma4"
IUSE+=" cpu_flags_x86_mmx cpu_flags_x86_mmxext"
IUSE+=" cpu_flags_x86_sse cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3 cpu_flags_x86_sse4_1"
IUSE+=" cpu_flags_x86_sse4_2 cpu_flags_x86_xop"
IUSE+=" cpu_flags_x86_3dnow cpu_flags_x86_3dnowext"
+IUSE+=" cpu_flags_arm_thumb cpu_flags_arm_neon cpu_flags_arm_vfp cpu_flags_arm_vfpv3"
+IUSE+=" cpu_flags_arm_iwmmxt"
IUSE+=" cpu_flags_ppc_altivec"
IUSE+=" a52 aalib +alsa aqua bidi bl bluray"
@@ -150,7 +153,7 @@ DEPEND="
xinerama? ( x11-base/xorg-proto )
xscreensaver? ( x11-base/xorg-proto )
"
-ASM_DEP="dev-lang/yasm"
+ASM_DEP="dev-lang/nasm"
BDEPEND="
virtual/pkgconfig
amd64? ( ${ASM_DEP} )
@@ -461,15 +464,21 @@ src_configure() {
# Platform specific flags, hardcoded on amd64 (see below)
use cpudetection && myconf+=( --enable-runtime-cpudetection )
- # TODO: refresh this list
- uses="3dnow 3dnowext avx avx2 fma3 fma4 mmx mmxext sse sse2 sse3 ssse3 xop"
- for i in ${uses}; do
+ local x86_uses="3dnow 3dnowext avx avx2 fma3 fma4 mmx mmxext sse sse2 sse3 ssse3 xop"
+ for i in ${x86_uses}; do
myconf+=( $(use_enable cpu_flags_x86_${i} ${i}) )
done
- myconf+=( $(use_enable cpu_flags_x86_sse4_1 sse4) )
- myconf+=( $(use_enable cpu_flags_x86_sse4_2 sse42) )
+ myconf+=(
+ $(use_enable cpu_flags_x86_sse4_1 sse4)
+ $(use_enable cpu_flags_x86_sse4_2 sse42)
+ )
myconf+=(
+ $(use_enable cpu_flags_arm_iwmmxt iwmmxt)
+ $(use_enable cpu_flags_arm_thumb thumb)
+ $(use_enable cpu_flags_arm_neon neon)
+ $(use_enable cpu_flags_arm_vfp armvfp)
+ $(use_enable cpu_flags_arm_vfpv3 vfpv3)
$(use_enable cpu_flags_ppc_altivec altivec)
$(use_enable shm)
)