summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/notus-scanner/notus-scanner-22.6.4-r1.ebuild (renamed from net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild)41
1 files changed, 14 insertions, 27 deletions
diff --git a/net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild b/net-analyzer/notus-scanner/notus-scanner-22.6.4-r1.ebuild
index 43056ee11d51..cc3cdd16a286 100644
--- a/net-analyzer/notus-scanner/notus-scanner-22.6.4.ebuild
+++ b/net-analyzer/notus-scanner/notus-scanner-22.6.4-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} pypy3 )
DISTUTILS_USE_PEP517=poetry
-inherit distutils-r1 readme.gentoo-r1 systemd
+inherit distutils-r1 greadme systemd
DESCRIPTION="Notus is a vulnerability scanner for creating results from local security checks"
HOMEPAGE="https://github.com/greenbone/notus-scanner"
@@ -34,58 +34,45 @@ PATCHES=(
"${FILESDIR}"/notus-scanner-22.6.2-remove-tests.patch
)
-DOC_CONTENTS="
-For validating the feed content, a GnuPG keychain with the Greenbone Community Feed integrity key needs to be created.
-Please, read here on how to create it:
-https://greenbone.github.io/docs/latest/22.4/source-build/index.html#feed-validation
-https://wiki.gentoo.org/wiki/Greenbone_Vulnerability_Management#Notus_Scanner
-
-To enable feed validation, edit /etc/gvm/${PN}.toml
-and set
-disable-hashsum-verification = false"
-DISABLE_AUTOFORMATTING=true
+GREADME_DISABLE_AUTOFORMAT=1
distutils_enable_tests unittest
-python_compile() {
- distutils-r1_python_compile
-}
-
python_install() {
distutils-r1_python_install
insinto /etc/gvm
- use prefix || fowners -R gvm:gvm /etc/gvm
newins "${FILESDIR}/${PN}.toml" "${PN}.toml"
- use prefix || fowners gvm:gvm "/etc/gvm/${PN}.toml"
# Set proper permissions on required files/directories
keepdir /var/lib/notus
keepdir /var/lib/notus/products
keepdir /var/lib/notus/advisories
+ keepdir /var/log/gvm
if ! use prefix; then
+ fowners -R gvm:gvm /etc/gvm
fowners -R gvm:gvm /var/lib/notus
+ fowners -R gvm:gvm /var/log/gvm
fi
# Adding notus-scanner.log to logrotate
insinto /etc/logrotate.d
newins "${FILESDIR}/${PN}.logrotate" "${PN}"
- # Set proper permissions on required files/directories
- keepdir /var/log/gvm
- if ! use prefix; then
- fowners -R gvm:gvm /var/log/gvm
- fi
-
newinitd "${FILESDIR}/${PN}.initd" "${PN}"
systemd_dounit config/${PN}.service
systemd_install_serviced "${FILESDIR}/notus-scanner.service.conf" \
${PN}.service
- readme.gentoo_create_doc
-}
-pkg_postinst() {
- readme.gentoo_print_elog
+ greadme_stdin <<-EOF
+For validating the feed content, a GnuPG keychain with the Greenbone Community Feed
+integrity key needs to be created. Please, read here on how to create it:
+ - https://greenbone.github.io/docs/latest/22.4/source-build/index.html#feed-validation
+ - https://wiki.gentoo.org/wiki/Greenbone_Vulnerability_Management#Notus_Scanner
+
+To enable feed validation, edit /etc/gvm/${PN}.toml and set
+ disable-hashsum-verification = false
+EOF
}