summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc/znc/files/znc-1.7.0-inttest-fix-make-warning.patch')
-rw-r--r--net-irc/znc/files/znc-1.7.0-inttest-fix-make-warning.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-irc/znc/files/znc-1.7.0-inttest-fix-make-warning.patch b/net-irc/znc/files/znc-1.7.0-inttest-fix-make-warning.patch
new file mode 100644
index 000000000000..0be20e4c08d0
--- /dev/null
+++ b/net-irc/znc/files/znc-1.7.0-inttest-fix-make-warning.patch
@@ -0,0 +1,26 @@
+From abee9f9bfc8c9ca9d4616238fdd812c4200b17d5 Mon Sep 17 00:00:00 2001
+From: Alexey Sokolov <alexey+znc@asokolov.org>
+Date: Thu, 28 Jun 2018 23:57:29 +0100
+Subject: [PATCH] Fix a warning in integration test / gmake / znc-buildmod
+ interaction.
+
+It was requested on https://github.com/gentoo/gentoo/pull/8901
+---
+ test/CMakeLists.txt | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
+index b19c22fab..296cb0de7 100644
+--- a/test/CMakeLists.txt
++++ b/test/CMakeLists.txt
+@@ -85,5 +85,10 @@ externalproject_add(inttest_bin
+ "-DZNC_BIN_DIR:path=${CMAKE_INSTALL_FULL_BINDIR}"
+ "-DQt5_HINTS:path=${brew_qt5}")
+ add_custom_target(inttest COMMAND
++ # Prevent a warning from test of znc-buildmod, when inner make
++ # discovers that there is an outer make and tries to use it:
++ # gmake[4]: warning: jobserver unavailable: using -j1. Add '+' to parent make rule.
++ # This option doesn't affect ninja, which doesn't show that warning anyway.
++ ${CMAKE_COMMAND} -E env MAKEFLAGS=
+ "${CMAKE_CURRENT_BINARY_DIR}/integration/inttest")
+ add_dependencies(inttest inttest_bin)