summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/nodejs/nodejs-14.16.1-r1.ebuild')
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 02e8c08318b3..0cc7ac183eeb 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -54,7 +54,15 @@ pkg_pretend() {
if [[ ${MERGE_TYPE} != "binary" ]]; then
if use lto; then
- tc-is-gcc || die "${PN} only supports LTO for gcc"
+ if tc-is-gcc; then
+ if [[ $(gcc-major-version) -ge 11 ]]; then
+ # Bug #787158
+ die "LTO builds of ${PN} using gcc-11+ currently fail tests and produce runtime errors. Either switch to gcc-10 or unset USE=lto for this ebuild"
+ fi
+ else
+ # configure.py will abort on this later if we do not
+ die "${PN} only supports LTO for gcc"
+ fi
fi
fi
}