summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/pycnb')
-rw-r--r--net-misc/pycnb/pycnb-0.0.4-r1.ebuild (renamed from net-misc/pycnb/pycnb-0.0.4.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-misc/pycnb/pycnb-0.0.4.ebuild b/net-misc/pycnb/pycnb-0.0.4-r1.ebuild
index f363f1ae810a..c6468e436465 100644
--- a/net-misc/pycnb/pycnb-0.0.4.ebuild
+++ b/net-misc/pycnb/pycnb-0.0.4-r1.ebuild
@@ -20,3 +20,9 @@ DEPEND="dev-python/cement[${PYTHON_USEDEP}]
dev-python/twisted-web
dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ find ${P} -type d -exec chmod 0755 {} + || die
+ find ${P} -type f -exec chmod 0644 {} + || die
+}