summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/flann/files/flann-1.9.1-system-lz4.patch')
-rw-r--r--sci-libs/flann/files/flann-1.9.1-system-lz4.patch18
1 files changed, 0 insertions, 18 deletions
diff --git a/sci-libs/flann/files/flann-1.9.1-system-lz4.patch b/sci-libs/flann/files/flann-1.9.1-system-lz4.patch
index dcc9fedd4a97..04ef15939284 100644
--- a/sci-libs/flann/files/flann-1.9.1-system-lz4.patch
+++ b/sci-libs/flann/files/flann-1.9.1-system-lz4.patch
@@ -3,16 +3,6 @@ Date: Sun, 14 Oct 2018 00:25:05 +0200
Subject: Use system version of liblz4
Also make sure that flann_cpp is linked against LZ4.
----
- CMakeLists.txt | 3 +++
- cmake/flann.pc.in | 2 +-
- examples/CMakeLists.txt | 3 +++
- src/cpp/CMakeLists.txt | 8 ++++++--
- src/cpp/flann/util/serialization.h | 4 ++--
- 5 files changed, 15 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index a01fb7a..995e54e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -142,6 +142,9 @@ if (BUILD_CUDA_LIB)
@@ -25,8 +15,6 @@ index a01fb7a..995e54e 100644
#set the C/C++ include path to the "include" directory
include_directories(BEFORE ${PROJECT_SOURCE_DIR}/src/cpp)
-diff --git a/cmake/flann.pc.in b/cmake/flann.pc.in
-index 82eee5e..07b8d64 100644
--- a/cmake/flann.pc.in
+++ b/cmake/flann.pc.in
@@ -8,6 +8,6 @@ Name: @PROJECT_NAME@
@@ -37,8 +25,6 @@ index 82eee5e..07b8d64 100644
+Libs: -L${libdir} @LZ4_STATIC_LDFLAGS@ -lflann -lflann_cpp
Cflags: -I${includedir}
-diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
-index e9fef04..2b2bb9d 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -3,6 +3,7 @@ add_custom_target(examples ALL)
@@ -65,8 +51,6 @@ index e9fef04..2b2bb9d 100644
target_link_libraries(flann_example_mpi flann_cpp ${HDF5_LIBRARIES} ${MPI_LIBRARIES} ${Boost_LIBRARIES})
add_dependencies(examples flann_example_mpi)
-diff --git a/src/cpp/CMakeLists.txt b/src/cpp/CMakeLists.txt
-index b453b27..5c4f693 100644
--- a/src/cpp/CMakeLists.txt
+++ b/src/cpp/CMakeLists.txt
@@ -4,11 +4,12 @@ add_definitions(-D_FLANN_VERSION=${FLANN_VERSION})
@@ -108,8 +92,6 @@ index b453b27..5c4f693 100644
if(MINGW AND OPENMP_FOUND)
target_link_libraries(flann gomp)
-diff --git a/src/cpp/flann/util/serialization.h b/src/cpp/flann/util/serialization.h
-index d731021..cdc2e5e 100644
--- a/src/cpp/flann/util/serialization.h
+++ b/src/cpp/flann/util/serialization.h
@@ -6,8 +6,8 @@