summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/drgeo')
-rw-r--r--sci-mathematics/drgeo/Manifest2
-rw-r--r--sci-mathematics/drgeo/drgeo-1.1.0.ebuild56
-rw-r--r--sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch61
-rw-r--r--sci-mathematics/drgeo/metadata.xml16
4 files changed, 135 insertions, 0 deletions
diff --git a/sci-mathematics/drgeo/Manifest b/sci-mathematics/drgeo/Manifest
new file mode 100644
index 000000000000..612ef3a452c9
--- /dev/null
+++ b/sci-mathematics/drgeo/Manifest
@@ -0,0 +1,2 @@
+DIST drgeo-1.1.0.tar.gz 1608361 SHA256 8c93bb637c11ca1647f90e0d97ea03d5938efddc36c2d73b40f15ff8df672216
+DIST drgeo-doc-1.5.tar.gz 2730242 SHA256 a6453dc630a40dd1c84ed90a7b7ff4fa3806e4e3ce01d149b59df29318255cb2
diff --git a/sci-mathematics/drgeo/drgeo-1.1.0.ebuild b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
new file mode 100644
index 000000000000..c82df5f42dd8
--- /dev/null
+++ b/sci-mathematics/drgeo/drgeo-1.1.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DOCN="${PN}-doc"
+DOCV="1.5"
+DOC="${DOCN}-${DOCV}"
+
+DESCRIPTION="Interactive geometry package"
+HOMEPAGE="http://www.ofset.org/drgeo"
+SRC_URI="
+ mirror://sourceforge/ofset/${P}.tar.gz
+ mirror://sourceforge/ofset/${DOC}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="nls"
+
+RDEPEND="
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0
+ dev-libs/libxml2:2
+ || (
+ >=dev-scheme/guile-1.8[deprecated]
+ =dev-scheme/guile-1.6*
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_configure() {
+ default
+ # Can't make the documentation as it depends on Hyperlatex which isn't
+ # yet in portage. Fortunately HTML is already compiled for us in the
+ # tarball and so can be installed. Just create the make install target.
+ cd "${WORKDIR}"/${DOC}
+ econf
+}
+
+src_install() {
+ default
+ if use nls; then
+ cd "${WORKDIR}"/${DOC}
+ else
+ cd "${WORKDIR}"/${DOC}/c
+ fi
+ emake install DESTDIR="${D}"
+}
diff --git a/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
new file mode 100644
index 000000000000..1d8e93e06fea
--- /dev/null
+++ b/sci-mathematics/drgeo/files/drgeo-1.1.0-gcc45.patch
@@ -0,0 +1,61 @@
+Fix build with GCC 4.5, fix random SIGSEGV
+
+http://bugs.gentoo.org/show_bug.cgi?id=322211
+https://bugzilla.redhat.com/show_bug.cgi?id=454045
+
+--- geo/drgeo_figure.h
++++ geo/drgeo_figure.h
+@@ -322,4 +322,11 @@
+ gboolean showGrid;
+ };
+
++struct
++{
++ drgeoPoint mouse;
++ drgeoFigure *figure;
++}
++drgeoDialogData;
++
+ #endif
+--- geo/drgeo_figure.cc
++++ geo/drgeo_figure.cc
+@@ -48,13 +48,6 @@
+ #include "drgeo_dialog.h"
+ #include "traite.h"
+
+-extern struct
+-{
+- drgeoPoint mouse;
+- drgeoFigure *figure;
+-}
+-drgeoDialogData;
+-
+ typedef struct drgeoSearchValue
+ {
+ gpointer value;
+@@ -1309,7 +1302,7 @@
+ gint
+ drgeoFigure::preferedUndoLevel ()
+ {
+- atoi (drgeoConfigGet (":undoLevel"));
++ return atoi (drgeoConfigGet (":undoLevel"));
+ }
+
+ void
+--- geo/drgeo_dialog.cc
++++ geo/drgeo_dialog.cc
+@@ -38,14 +38,6 @@
+ // Used in the style dialod callback, I know it's ugly, but so easy
+ static drgeoFigure *selected_figure;
+
+-struct
+-{
+- drgeoPoint mouse;
+- drgeoFigure *figure;
+-}
+-drgeoDialogData;
+-
+-
+ static void drgeo_edit_dialog_cb (GtkWidget * dialog,
+ gint button, gpointer entry);
+
diff --git a/sci-mathematics/drgeo/metadata.xml b/sci-mathematics/drgeo/metadata.xml
new file mode 100644
index 000000000000..644b7bab5c8e
--- /dev/null
+++ b/sci-mathematics/drgeo/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-mathematics</herd>
+ <longdescription lang="en">
+ Dr. Geo is a GTK2 interactive geometry software. It allows one to
+ create geometric figure plus the interactive manipulation of
+ such figure in respect with their geometric constraints. It is
+ useable in teaching situation with students from primary or
+ secondary level. It also features an integrated Scheme
+ programming language to define scripts within a figure.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">ofset</remote-id>
+ </upstream>
+</pkgmetadata>