summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild')
-rw-r--r--sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild b/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild
index 74f541639c16..d696ca7b9817 100644
--- a/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild
+++ b/sci-mathematics/normaliz/normaliz-3.8.10-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,8 +25,12 @@ DEPEND="
"
# Only a boost header is needed -> not RDEPEND
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
pkg_setup() {
- use openmp && tc-check-openmp
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
src_prepare() {