summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/stp/files/stp-2.3.3-CMakeLists.txt-fix_cflags.patch')
-rw-r--r--sci-mathematics/stp/files/stp-2.3.3-CMakeLists.txt-fix_cflags.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-mathematics/stp/files/stp-2.3.3-CMakeLists.txt-fix_cflags.patch b/sci-mathematics/stp/files/stp-2.3.3-CMakeLists.txt-fix_cflags.patch
new file mode 100644
index 000000000000..93817e209376
--- /dev/null
+++ b/sci-mathematics/stp/files/stp-2.3.3-CMakeLists.txt-fix_cflags.patch
@@ -0,0 +1,21 @@
+index f6224a6..8c7c45e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -203,17 +203,9 @@ if (NOT MSVC)
+ add_compile_options( -g)
+ add_compile_options( -pthread )
+
+- add_compile_options("$<$<CONFIG:RELWITHDEBINFO>:-O2>")
+-
+- add_compile_options("$<$<CONFIG:RELEASE>:-O2>")
+ add_compile_options("$<$<CONFIG:RELEASE>:-g0>")
+
+ add_compile_options("$<$<CONFIG:DEBUG>:-O0>")
+-
+- if(NOT CMAKE_BUILD_TYPE STREQUAL "Debug")
+- set(CMAKE_SHARED_LINKER_FLAGS "${CMAKE_SHARED_LINKER_FLAGS} -O2")
+- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -O2")
+- endif()
+ else()
+ # see https://msdn.microsoft.com/en-us/library/fwkeyyhe.aspx for details
+ # /ZI = include debug info