summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/man2html/man2html-1.6g.ebuild')
-rw-r--r--sys-apps/man2html/man2html-1.6g.ebuild27
1 files changed, 15 insertions, 12 deletions
diff --git a/sys-apps/man2html/man2html-1.6g.ebuild b/sys-apps/man2html/man2html-1.6g.ebuild
index 9027484ba531..b84b64315a1e 100644
--- a/sys-apps/man2html/man2html-1.6g.ebuild
+++ b/sys-apps/man2html/man2html-1.6g.ebuild
@@ -1,33 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit epatch toolchain-funcs
+inherit toolchain-funcs
MY_P="man-${PV}"
DESCRIPTION="Standard commands to read man pages"
HOMEPAGE="http://primates.ximian.com/~flucifredi/man/"
SRC_URI="http://primates.ximian.com/~flucifredi/man/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE=""
RDEPEND="!sys-apps/man"
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- epatch "${FILESDIR}"/man-1.6f-man2html-compression-2.patch
- epatch "${FILESDIR}"/man-1.6-cross-compile.patch
- epatch "${FILESDIR}"/man-1.6g-compress.patch #205147
-}
+PATCHES=(
+ "${FILESDIR}"/man-1.6f-man2html-compression-2.patch
+ "${FILESDIR}"/man-1.6-cross-compile.patch
+ "${FILESDIR}"/man-1.6g-compress.patch #205147
+)
-echoit() { echo "$@" ; "$@" ; }
src_configure() {
+ echoit() {
+ echo "$@"
+ "$@"
+ }
+
tc-export CC BUILD_CC
# Just a stub to disable configure check. man2html doesn't use it.
@@ -48,7 +50,8 @@ src_compile() {
src_install() {
# A little faster to run this by hand than `emake install`.
- cd man2html
+ cd man2html || die
+
dobin man2html
doman man2html.1
dodoc README TODO