summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sysvinit/Manifest2
-rw-r--r--sys-apps/sysvinit/metadata.xml19
-rw-r--r--sys-apps/sysvinit/sysvinit-3.02.ebuild175
3 files changed, 188 insertions, 8 deletions
diff --git a/sys-apps/sysvinit/Manifest b/sys-apps/sysvinit/Manifest
index 439c1fbdc297..4aa02107a44b 100644
--- a/sys-apps/sysvinit/Manifest
+++ b/sys-apps/sysvinit/Manifest
@@ -1,3 +1,5 @@
DIST sysvinit-2.99.tar.xz 126908 BLAKE2B b82c745d5b695f918d4a163e7b9eaceccc07a46f73c3782c7771cc29a8600be13de4ff30891086df5773d60f37fa3b0f58566ccaf72cd70af68083b51152a38b SHA512 34f328d7d2e6ceddcddfebab49eb9c34e90dc96decf2caeb89dffd2ade54322fa4a3cb9fa1e1a4bc687e07fcb0a13e5aebe6186582a9f5c9153e1513baa87ddd
DIST sysvinit-3.00.tar.xz 127072 BLAKE2B d1c4e509d7c13cf0fb9da290f875e7c0ab0666d843d75d4dd6885112248a859dd077bdf9cc926c4af58473da99a5229bb879c7094afd648d5ebe72597a3ba6a7 SHA512 ba834ac6c48528304373018bfb05dcdd3573d8081dd7dc95a44808804404d77ee4832fedb3f34e67d87f22f201f9526c54910a51c6ed2a42ac55b756843cd825
DIST sysvinit-3.01.tar.xz 126616 BLAKE2B b991c6d2a09b02003cc587379b148f8ca3817c27fcaf81f184f679cfd5325e0b551484bba47bb554a34c7eeba60538f4943de49b1d59bd4bef73d7d086fefdb2 SHA512 66da3830aa32b70f0beea994213145a550e5b5d58a5b54afb17109243d5efface6aba8c296b76dbfb22ce6f86c9c58f237ff71ee04ec7d5b316ad412bf7acbcf
+DIST sysvinit-3.02.tar.xz 219560 BLAKE2B c68505aab9e257fa3fb4153b4d2a51a7a8ac0137f0ee21174c168b1a1e4f12ea6be53679c484e2ea31904a37cd94fb5d913a9885da6c618acdae566b70bb7fae SHA512 44a43e2faff3a0d3410447ffc9b8b7c66eae1a5cba54c2c4d8518d3b2e5accecc68a280c87dbf6d18f943ae466c3c1e09bc633009207cbd777d371effda30831
+DIST sysvinit-3.02.tar.xz.sig 833 BLAKE2B 07f86211d2ded8afea22df246140cb44ec4a949c2450b1cc9d996b4b582da7767726648595c5f1cf584c31c0c59c4b0915a22cc254fed56bd42ac155b544cbfc SHA512 9b8a2b3e480041ead8bd2b16551fb00e387d823ad196cf60f6938eda5accf33e944b7b530d47bc0bdd90de6766cf8d44050c0c3d95b18c8b76d412d0a6c3121a
diff --git a/sys-apps/sysvinit/metadata.xml b/sys-apps/sysvinit/metadata.xml
index 244cfb040246..f085bc59b51f 100644
--- a/sys-apps/sysvinit/metadata.xml
+++ b/sys-apps/sysvinit/metadata.xml
@@ -1,12 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="person">
- <email>williamh@gentoo.org</email>
- <name>William Hubbs</name>
-</maintainer>
-<maintainer type="project">
- <email>base-system@gentoo.org</email>
- <name>Gentoo Base System</name>
-</maintainer>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">slicer69/sysvinit</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/sys-apps/sysvinit/sysvinit-3.02.ebuild b/sys-apps/sysvinit/sysvinit-3.02.ebuild
new file mode 100644
index 000000000000..44203391cf14
--- /dev/null
+++ b/sys-apps/sysvinit/sysvinit-3.02.ebuild
@@ -0,0 +1,175 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PLOCALES="de es fi fr hu id pl"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/sysvinit.asc
+inherit toolchain-funcs flag-o-matic plocale verify-sig
+
+DESCRIPTION="/sbin/init - parent of all processes"
+HOMEPAGE="https://savannah.nongnu.org/projects/sysvinit"
+SRC_URI="mirror://nongnu/${PN}/${P/_/-}.tar.xz"
+SRC_URI+=" verify-sig? ( mirror://nongnu/${PN}/${P/_/-}.tar.xz.sig )"
+S="${WORKDIR}/${P/_*}"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} != *beta* ]] ; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+IUSE="selinux ibm nls static"
+
+COMMON_DEPEND="
+ selinux? (
+ >=sys-libs/libselinux-1.28
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/os-headers"
+RDEPEND="${COMMON_DEPEND}
+ selinux? ( sec-policy/selinux-shutdown )"
+# po4a is for man page translations
+BDEPEND="nls? ( app-text/po4a )
+ verify-sig? ( sec-keys/openpgp-keys-sysvinit )"
+
+PATCHES=(
+ # bug #80220
+ "${FILESDIR}/${PN}-2.86-kexec.patch"
+ # bug #158615
+ "${FILESDIR}/${PN}-2.94_beta-shutdown-single.patch"
+)
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/^CPPFLAGS =$/d' \
+ -e '/^override CFLAGS +=/s/ -fstack-protector-strong//' \
+ src/Makefile || die
+
+ # last/lastb/mesg/mountpoint/sulogin/utmpdump/wall have moved to util-linux
+ sed -i -r \
+ -e '/^(USR)?S?BIN/s:\<(last|lastb|mesg|mountpoint|sulogin|utmpdump|wall)\>::g' \
+ -e '/^MAN[18]/s:\<(last|lastb|mesg|mountpoint|sulogin|utmpdump|wall)[.][18]\>::g' \
+ src/Makefile || die
+
+ # pidof has moved to >=procps-3.3.9
+ sed -i -r \
+ -e '/\/bin\/pidof/d' \
+ -e '/^MAN8/s:\<pidof.8\>::g' \
+ src/Makefile || die
+
+ # logsave is already in e2fsprogs
+ sed -i -r \
+ -e '/^(USR)?S?BIN/s:\<logsave\>::g' \
+ -e '/^MAN8/s:\<logsave.8\>::g' \
+ src/Makefile || die
+
+ # Mung inittab for specific architectures
+ cd "${WORKDIR}" || die
+ cp "${FILESDIR}"/inittab-2.98-r1 inittab || die "cp inittab"
+ local insert=()
+ use ppc && insert=( '#psc0:12345:respawn:/sbin/agetty 115200 ttyPSC0 linux' )
+ use arm && insert=( '#f0:12345:respawn:/sbin/agetty 9600 ttyFB0 vt100' )
+ use arm64 && insert=( 'f0:12345:respawn:/sbin/agetty 9600 ttyAMA0 vt100' )
+ use hppa && insert=( 'b0:12345:respawn:/sbin/agetty 9600 ttyB0 vt100' )
+ use s390 && insert=( 's0:12345:respawn:/sbin/agetty 38400 console dumb' )
+ if use ibm ; then
+ insert+=(
+ '#hvc0:2345:respawn:/sbin/agetty -L 9600 hvc0'
+ '#hvsi:2345:respawn:/sbin/agetty -L 19200 hvsi0'
+ )
+ fi
+ (use arm || use mips || use sparc) && sed -i '/ttyS0/s:#::' inittab
+ if use x86 || use amd64 ; then
+ sed -i \
+ -e '/ttyS[01]/s:9600:115200:' \
+ inittab
+ fi
+
+ if [[ ${#insert[@]} -gt 0 ]] ; then
+ printf '%s\n' '' '# Architecture specific features' "${insert[@]}" >> inittab
+ fi
+
+ delete_unused_locale() {
+ local locale=${1}
+
+ einfo "Deleting non-requested man page translations for locale=${locale}"
+ rm "${S}"/man/po/${locale}.po || die
+
+ sed -i -e "/^\[po4a_langs\]/ s:${locale}::" "${S}"/man/po/po4a.cfg || die
+ }
+
+ plocale_for_each_disabled_locale delete_unused_locale
+}
+
+src_compile() {
+ tc-export CC
+
+ append-lfs-flags
+
+ # bug #381311
+ export DISTRO=
+ export VERSION="${PV}"
+
+ use static && append-ldflags -static
+ emake -C src $(usex selinux 'WITH_SELINUX=yes' '')
+
+ if use nls && [[ -n "$(plocale_get_locales)" ]] ; then
+ cd man/po || die
+ po4a po4a.cfg || die
+ fi
+}
+
+src_install() {
+ emake -C src install ROOT="${D}"
+ dodoc README doc/*
+
+ insinto /etc
+ doins "${WORKDIR}"/inittab
+
+ newinitd "${FILESDIR}"/bootlogd.initd bootlogd
+ newconfd "${FILESDIR}"/bootlogd.confd bootlogd
+
+ into /
+ dosbin "${FILESDIR}"/halt.sh
+
+ keepdir /etc/inittab.d
+
+ if use nls && [[ -n "$(plocale_get_locales)" ]] ; then
+ install_locale_man_pages() {
+ local locale=${1}
+
+ doman -i18n=${locale} man/po/${locale}/*
+ }
+
+ plocale_for_each_locale install_locale_man_pages
+ fi
+
+ # Dead symlink
+ find "${ED}" -xtype l -delete || die
+
+ find "${ED}" -type d -empty -delete || die
+}
+
+pkg_postinst() {
+ # Reload init to fix unmounting problems of / on next reboot.
+ # This is really needed, as without the new version of init cause init
+ # not to quit properly on reboot, and causes a fsck of / on next reboot.
+ if [[ -z ${ROOT} ]] ; then
+ if [[ -e /dev/initctl ]] && [[ ! -e /run/initctl ]] ; then
+ ln -s /dev/initctl /run/initctl \
+ || ewarn "Failed to set /run/initctl symlink!"
+ fi
+ # Do not return an error if this fails
+ /sbin/telinit U &>/dev/null
+ fi
+
+ elog "The last/lastb/mesg/mountpoint/sulogin/utmpdump/wall tools have been moved to"
+ elog "sys-apps/util-linux. The pidof tool has been moved to sys-process/procps."
+
+ # Required for new bootlogd service
+ if [[ ! -e "${EROOT}/var/log/boot" ]] ; then
+ touch "${EROOT}/var/log/boot"
+ fi
+}