summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/clang/clang-9.0.0.ebuild')
-rw-r--r--sys-devel/clang/clang-9.0.0.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/sys-devel/clang/clang-9.0.0.ebuild b/sys-devel/clang/clang-9.0.0.ebuild
index e72ceac433ba..4a4b325876a8 100644
--- a/sys-devel/clang/clang-9.0.0.ebuild
+++ b/sys-devel/clang/clang-9.0.0.ebuild
@@ -21,6 +21,8 @@ SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz
https://releases.llvm.org/${PV}/${EXTRA_P}.tar.xz
test? ( https://releases.llvm.org/${PV}/${LLVM_P}.tar.xz )
!doc? ( https://dev.gentoo.org/~mgorny/dist/llvm/llvm-${PV}-manpages.tar.bz2 )"
+# We need extra level of indirection for CLANG_RESOURCE_DIR
+S=${WORKDIR}/x/y/${MY_P}
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -36,6 +38,8 @@ SLOT="$(ver_cut 1)"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux"
IUSE="debug default-compiler-rt default-libcxx doc +static-analyzer
test xml kernel_FreeBSD ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ || ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -59,12 +63,6 @@ PDEPEND="
default-compiler-rt? ( =sys-libs/compiler-rt-${PV%_*}* )
default-libcxx? ( >=sys-libs/libcxx-${PV} )"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- || ( ${ALL_LLVM_TARGETS[*]} )"
-
-# We need extra level of indirection for CLANG_RESOURCE_DIR
-S=${WORKDIR}/x/y/${MY_P}
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo