summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/rar2fs/rar2fs-1.29.1.ebuild')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.29.1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.29.1.ebuild b/sys-fs/rar2fs/rar2fs-1.29.1.ebuild
index e7b7be74efd1..cc417da24599 100644
--- a/sys-fs/rar2fs/rar2fs-1.29.1.ebuild
+++ b/sys-fs/rar2fs/rar2fs-1.29.1.ebuild
@@ -3,6 +3,8 @@
EAPI=7
+inherit autotools
+
DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
@@ -19,6 +21,15 @@ RDEPEND=">=app-arch/unrar-5:=
sys-fs/fuse:0"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.29.1-no-compress-man.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
export USER_CFLAGS="${CFLAGS}"