summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/newlib/newlib-2.4.0.ebuild')
-rw-r--r--sys-libs/newlib/newlib-2.4.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/sys-libs/newlib/newlib-2.4.0.ebuild b/sys-libs/newlib/newlib-2.4.0.ebuild
index 12999bcabf4e..428276464d38 100644
--- a/sys-libs/newlib/newlib-2.4.0.ebuild
+++ b/sys-libs/newlib/newlib-2.4.0.ebuild
@@ -53,10 +53,15 @@ src_configure() {
unset LDFLAGS
CHOST=${CTARGET} strip-unsupported-flags
- local myconf=""
+ local myconf=(
+ # Disable legacy syscall stub code in newlib. These have been
+ # moved to libgloss for a long time now, so the code in newlib
+ # itself just gets in the way.
+ --disable-newlib-supplied-syscalls
+ )
[[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-newlib-multithread" \
- || myconf="${myconf} $(use_enable threads newlib-multithread)"
+ && myconf+=( --disable-newlib-multithread ) \
+ || myconf+=( $(use_enable threads newlib-multithread) )
mkdir -p "${NEWLIBBUILD}"
cd "${NEWLIBBUILD}"
@@ -65,7 +70,7 @@ src_configure() {
econf \
$(use_enable unicode newlib-mb) \
$(use_enable nls) \
- ${myconf}
+ "${myconf[@]}"
}
src_compile() {