summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild2
5 files changed, 5 insertions, 5 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild b/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild
index e2a452caad61..2a724ca7dd8c 100644
--- a/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-18.1.4.ebuild
@@ -90,7 +90,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild b/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild
index e2a452caad61..2a724ca7dd8c 100644
--- a/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-18.1.5.ebuild
@@ -90,7 +90,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild
index 46de84f27ba9..ec82b06b9c24 100644
--- a/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-19.0.0.9999.ebuild
@@ -89,7 +89,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild
index 46de84f27ba9..ec82b06b9c24 100644
--- a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240427.ebuild
@@ -89,7 +89,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"
diff --git a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild
index 46de84f27ba9..ec82b06b9c24 100644
--- a/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-19.0.0_pre20240504.ebuild
@@ -89,7 +89,7 @@ src_configure() {
elif test_compiler "${nolib_flags[@]}" -nostartfiles; then
# Avoiding -nostartfiles earlier on for bug #862540,
# and set available entry symbol for bug #862798.
- nolib_flags+=( -nostartfiles -emain )
+ nolib_flags+=( -nostartfiles -e main )
local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
ewarn "${CC} seems to lack runtime, trying with ${nolib_flags[*]}"