summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/lsof/lsof-4.99.3.ebuild')
-rw-r--r--sys-process/lsof/lsof-4.99.3.ebuild13
1 files changed, 13 insertions, 0 deletions
diff --git a/sys-process/lsof/lsof-4.99.3.ebuild b/sys-process/lsof/lsof-4.99.3.ebuild
index c22f1df517e3..591b4742d2de 100644
--- a/sys-process/lsof/lsof-4.99.3.ebuild
+++ b/sys-process/lsof/lsof-4.99.3.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit autotools
+
MY_P="${P/-/_}"
DESCRIPTION="Lists open files for running Unix processes"
HOMEPAGE="https://github.com/lsof-org/lsof"
@@ -26,6 +28,17 @@ BDEPEND="
# Needs fixing first for sandbox
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.98.0-fix-clang-version-parser.patch
+)
+
+# TODO: drop this block, "inherit autotools" and clang-version-parser patch after 4.99.3
+# https://github.com/lsof-org/lsof/pull/306
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
local myeconfargs=(
$(use_with rpc libtirpc)