summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-91.0.4472.77.ebuild')
-rw-r--r--www-client/chromium/chromium-91.0.4472.77.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-91.0.4472.77.ebuild b/www-client/chromium/chromium-91.0.4472.77.ebuild
index 9b7392341078..2b6dd7b1b6ee 100644
--- a/www-client/chromium/chromium-91.0.4472.77.ebuild
+++ b/www-client/chromium/chromium-91.0.4472.77.ebuild
@@ -15,14 +15,16 @@ DESCRIPTION="Open-source version of Google Chrome web browser"
HOMEPAGE="https://chromium.org/"
PATCHSET="6"
PATCHSET_NAME="chromium-$(ver_cut 1)-patchset-${PATCHSET}"
+PPC64LE_PATCHSET="5"
SRC_URI="https://commondatastorage.googleapis.com/chromium-browser-official/${P}.tar.xz
https://files.pythonhosted.org/packages/ed/7b/bbf89ca71e722b7f9464ebffe4b5ee20a9e5c9a555a56e2d3914bb9119a6/setuptools-44.1.0.zip
https://github.com/stha09/chromium-patches/releases/download/${PATCHSET_NAME}/${PATCHSET_NAME}.tar.xz
- arm64? ( https://github.com/google/highway/archive/refs/tags/0.12.1.tar.gz -> highway-0.12.1.tar.gz )"
+ arm64? ( https://github.com/google/highway/archive/refs/tags/0.12.1.tar.gz -> highway-0.12.1.tar.gz )
+ ppc64? ( https://dev.gentoo.org/~gyakovlev/distfiles/${PN}-$(ver_cut 1)-ppc64le-${PPC64LE_PATCHSET}.tar.xz )"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="component-build cups cpu_flags_arm_neon +hangouts headless +js-type-check kerberos official pic +proprietary-codecs pulseaudio screencast selinux +suid +system-ffmpeg +system-icu vaapi wayland widevine"
REQUIRED_USE="
component-build? ( !suid )
@@ -243,6 +245,8 @@ src_prepare() {
)
fi
+ use ppc64 && eapply -p0 "${WORKDIR}/${PN}"-ppc64le
+
default
mkdir -p third_party/node/linux/node-linux-x64/bin || die
@@ -741,6 +745,9 @@ src_configure() {
append-cxxflags -flax-vector-conversions
fi
+ # highway/libjxl fail on ppc64 without extra patches, disable for now.
+ use ppc64 && myconf_gn+=" enable_jxl_decoder=false"
+
# Disable unknown warning message from clang.
tc-is-clang && append-flags -Wno-unknown-warning-option