summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/moonbridge')
-rw-r--r--www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch14
-rw-r--r--www-servers/moonbridge/moonbridge-1.0.1.ebuild5
2 files changed, 18 insertions, 1 deletions
diff --git a/www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch b/www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch
new file mode 100644
index 000000000000..2a1d15b09238
--- /dev/null
+++ b/www-servers/moonbridge/files/moonbridge-1.0.1-fcntl.patch
@@ -0,0 +1,14 @@
+#It is explicitely required to include fcntl.h in musl.
+#Else we get F_SETFD, FD_CLOEXEC undefined errors.
+#
+#Closes: https://bugs.gentoo.org/828671
+--- a/moonbridge.c
++++ b/moonbridge.c
+@@ -36,6 +36,7 @@
+ #include <getopt.h>
+ #include <sys/file.h>
+ #include <syslog.h>
++#include <fcntl.h>
+ #if defined(__FreeBSD__) || __has_include(<libutil.h>)
+ #include <libutil.h>
+ #endif
diff --git a/www-servers/moonbridge/moonbridge-1.0.1.ebuild b/www-servers/moonbridge/moonbridge-1.0.1.ebuild
index 93fb08c942b9..c718ae8e1f34 100644
--- a/www-servers/moonbridge/moonbridge-1.0.1.ebuild
+++ b/www-servers/moonbridge/moonbridge-1.0.1.ebuild
@@ -27,7 +27,10 @@ BDEPEND="sys-devel/pmake
S="${WORKDIR}"/${MYP}
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-fcntl.patch
+)
DOCS=( README reference.txt )