summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/uwsgi')
-rw-r--r--www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild b/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild
index 248929d1ca5b..e9923f5a2ebc 100644
--- a/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild
+++ b/www-servers/uwsgi/uwsgi-2.0.17.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -79,17 +79,22 @@ REQUIRED_USE="|| ( ${LANG_SUPPORT_SIMPLE[@]} ${LANG_SUPPORT_EXTENDED[@]} )
# 2. General features
# 3. Plugins
# 4. Language/app support
-CDEPEND="sys-libs/zlib
+CDEPEND="
+ sys-libs/zlib
caps? ( sys-libs/libcap )
- json? ( !yajl? ( dev-libs/jansson )
- yajl? ( dev-libs/yajl ) )
+ json? (
+ !yajl? ( dev-libs/jansson )
+ yajl? ( dev-libs/yajl )
+ )
pcre? ( dev-libs/libpcre:3 )
ssl? (
- !libressl? ( dev-libs/openssl:0 )
+ !libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl )
)
- xml? ( !expat? ( dev-libs/libxml2 )
- expat? ( dev-libs/expat ) )
+ xml? (
+ !expat? ( dev-libs/libxml2 )
+ expat? ( dev-libs/expat )
+ )
yaml? ( dev-libs/libyaml )
zeromq? ( net-libs/zeromq sys-apps/util-linux )
uwsgi_plugins_alarm_curl? ( net-misc/curl )