summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/amlc/amlc-0.5.1.ebuild')
-rw-r--r--x11-apps/amlc/amlc-0.5.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-apps/amlc/amlc-0.5.1.ebuild b/x11-apps/amlc/amlc-0.5.1.ebuild
new file mode 100644
index 000000000000..6b0f94cfe94e
--- /dev/null
+++ b/x11-apps/amlc/amlc-0.5.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="Another Modeline Calculator, generates quality X11 display configs easily"
+HOMEPAGE="http://sourceforge.net/projects/amlc.berlios/"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.cpp"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}
+
+src_prepare() {
+ cp "${DISTDIR}"/${P}.cpp "${S}"
+}
+
+src_compile() {
+ $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} ${P}.cpp -o ${PN} || die
+}
+
+src_install() {
+ dobin ${PN}
+}