summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild')
-rw-r--r--x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..bb0dee3026ca
--- /dev/null
+++ b/x11-plugins/gkrellstock/gkrellstock-0.5.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit flag-o-matic gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Get Stock quotes plugin for Gkrellm2"
+HOMEPAGE="http://gkrellstock.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellstock/${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-admin/gkrellm[X]
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ dev-perl/libwww-perl
+ dev-perl/Finance-Quote
+"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${P/s/S}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-0.5-ldflags.patch
+ append-cppflags $($(tc-getPKG_CONFIG) --cflags gtk+-2.0)
+ append-flags -fPIC
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install () {
+ gkrellm-plugin_src_install
+ dobin GetQuote2
+}