summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmcoincoin')
-rw-r--r--x11-plugins/wmcoincoin/Manifest3
-rw-r--r--x11-plugins/wmcoincoin/metadata.xml14
-rw-r--r--x11-plugins/wmcoincoin/wmcoincoin-2.5.1f.ebuild37
-rw-r--r--x11-plugins/wmcoincoin/wmcoincoin-2.6.1.ebuild37
-rw-r--r--x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild46
5 files changed, 137 insertions, 0 deletions
diff --git a/x11-plugins/wmcoincoin/Manifest b/x11-plugins/wmcoincoin/Manifest
new file mode 100644
index 000000000000..374a2f90be4b
--- /dev/null
+++ b/x11-plugins/wmcoincoin/Manifest
@@ -0,0 +1,3 @@
+DIST wmcoincoin-2.5.1f.tar.gz 847541 SHA256 9758327599afb3281bf483db1fec03bd2574f5cb45a45bac7995c889eddef48e
+DIST wmcoincoin-2.6.1.tar.gz 963391 SHA256 c466433ac1cd8a018dfe87f33cb8832ce1e1c10714907e3eed94723c792bb140 SHA512 25027af9d1a0a05ea3b5b0856f6316d0f3409e6f7f02d2611f3e8dbaca72285b8b0a05a8aa2ed8a88af12f05f01821eeaebb1c0272e68ef1fa43459dd6d09da9 WHIRLPOOL bdecac8f249ed2ab598f119504f6b113a04364fa1392e0ac9a5a0d870c2c616e2aff703e062677523355a63f57ea5dda87c582a1499b62d82fb378a00ab79dde
+DIST wmcoincoin-2.6.2_p20140602.tar.gz 972358 SHA256 e6afdf6ceeaec81327fbeb8d823ac97d4e3372c312b53ac83014c690ca364cf9 SHA512 ddf1b24d9c9021e9cb02817e80f3327074ef7d09ba7d8033d5d0c8b39a25106a1d54d32f211d31a910e2175d98bbda940f309cc137edd1b02b5a656891e89b2c WHIRLPOOL 031ac936551d4975f460b44cfe715e1b3f21d263fc299fadf0dee9f686a3f49cf879c603aae5e2ffa547a33b590410edde8c2e7768fdcb9e021887bb0baa8532
diff --git a/x11-plugins/wmcoincoin/metadata.xml b/x11-plugins/wmcoincoin/metadata.xml
new file mode 100644
index 000000000000..60ca5d69bc5b
--- /dev/null
+++ b/x11-plugins/wmcoincoin/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+ <longdescription>
+wmCoinCoin is a WindowMaker dockapp that lets you see the latest news from
+linuxfr.org. It also graphically represents some statistics about the oneliner
+and the clients used to post on it. It also has the ability to post a
+customized message to this oneliner.
+</longdescription>
+ <upstream>
+ <remote-id type="github">d-torrance/wmcoincoin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/wmcoincoin/wmcoincoin-2.5.1f.ebuild b/x11-plugins/wmcoincoin/wmcoincoin-2.5.1f.ebuild
new file mode 100644
index 000000000000..703e3b4773b8
--- /dev/null
+++ b/x11-plugins/wmcoincoin/wmcoincoin-2.5.1f.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="a dockapp for browsing dacode news and board sites"
+HOMEPAGE="http://hules.free.fr/wmcoincoin"
+SRC_URI="http://hules.free.fr/${PN}/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls xinerama"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/imlib2
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}
diff --git a/x11-plugins/wmcoincoin/wmcoincoin-2.6.1.ebuild b/x11-plugins/wmcoincoin/wmcoincoin-2.6.1.ebuild
new file mode 100644
index 000000000000..a35c6cafab86
--- /dev/null
+++ b/x11-plugins/wmcoincoin/wmcoincoin-2.6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="a dockapp for browsing dacode news and board sites"
+HOMEPAGE="http://hules.free.fr/wmcoincoin"
+SRC_URI="http://hules.free.fr/${PN}/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls xinerama"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/imlib2
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}
diff --git a/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild b/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild
new file mode 100644
index 000000000000..a7aae7a9babd
--- /dev/null
+++ b/x11-plugins/wmcoincoin/wmcoincoin-2.6.2_p20140602.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="a dockapp for browsing dacode news and board sites"
+HOMEPAGE="http://hules.free.fr/wmcoincoin"
+# Grab matching tag and Debian patches
+SRC_URI="https://github.com/d-torrance/${PN}/archive/debian/${PV/_p/+}-1.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="nls xinerama"
+
+RDEPEND="x11-libs/gtk+:2
+ media-libs/imlib2
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11
+ x11-libs/libXft
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-libs/libXt
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+S=${WORKDIR}/${PN}-debian-${PV/_p/-}-1
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_prepare() {
+ EPATCH_SOURCE="${S}/debian/patches" EPATCH_SUFFIX=patch EPATCH_FORCE=yes epatch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable xinerama)
+}