summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmdots')
-rw-r--r--x11-plugins/wmdots/Manifest1
-rw-r--r--x11-plugins/wmdots/files/wmdots-0.2_beta-stringh.patch11
-rw-r--r--x11-plugins/wmdots/metadata.xml5
-rw-r--r--x11-plugins/wmdots/wmdots-0.2_beta.ebuild44
4 files changed, 61 insertions, 0 deletions
diff --git a/x11-plugins/wmdots/Manifest b/x11-plugins/wmdots/Manifest
new file mode 100644
index 000000000000..5c3730449b05
--- /dev/null
+++ b/x11-plugins/wmdots/Manifest
@@ -0,0 +1 @@
+DIST wmdots-0.2beta.tar.gz 94933 RMD160 11ffec8d242ed0d2835589565457f72dfe28a215 SHA1 7f021a3a66eaa26aff54473ad33321e4bc0fcd96 SHA256 c25be89d9f0ae840dff68034663524591f9e33fc7bba0c7b264f39ca08fc8c9e
diff --git a/x11-plugins/wmdots/files/wmdots-0.2_beta-stringh.patch b/x11-plugins/wmdots/files/wmdots-0.2_beta-stringh.patch
new file mode 100644
index 000000000000..129b938619ee
--- /dev/null
+++ b/x11-plugins/wmdots/files/wmdots-0.2_beta-stringh.patch
@@ -0,0 +1,11 @@
+diff -ur wmdots.orig/wmdots.c wmdots/wmdots.c
+--- wmdots.orig/wmdots.c 1999-10-11 22:39:11.000000000 +0300
++++ wmdots/wmdots.c 2008-01-06 15:18:26.000000000 +0200
+@@ -83,6 +83,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <unistd.h>
++#include <string.h>
+
+ #include <X11/xpm.h>
+ #include "../wmgeneral/wmgeneral.h"
diff --git a/x11-plugins/wmdots/metadata.xml b/x11-plugins/wmdots/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmdots/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdots/wmdots-0.2_beta.ebuild b/x11-plugins/wmdots/wmdots-0.2_beta.ebuild
new file mode 100644
index 000000000000..c7bcd16a68bb
--- /dev/null
+++ b/x11-plugins/wmdots/wmdots-0.2_beta.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="multishape 3d rotating dots"
+HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/116"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/153/${P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-stringh.patch
+ sed -e "s:cc:$(tc-getCC):g" \
+ -e "s:-g -O2:${CFLAGS}:g" -i Makefile
+
+ #Fix compilation target
+ sed -e "s:wmifs:wmdots:" -i Makefile
+
+ #Honour Gentoo LDFLAGS, see bug #336982
+ sed -e "s:-o wmdots:\$(LDFLAGS) -o wmdots:" -i Makefile
+}
+
+src_compile() {
+ emake clean || die "emake clean failed."
+ emake LIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
+}
+
+src_install() {
+ dobin wmdots
+}