summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines')
-rw-r--r--x11-themes/gtk-engines/Manifest1
-rw-r--r--x11-themes/gtk-engines/files/gtk-engines-2.20.2-glib.h.patch26
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild53
-rw-r--r--x11-themes/gtk-engines/metadata.xml13
4 files changed, 93 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines/Manifest b/x11-themes/gtk-engines/Manifest
new file mode 100644
index 000000000000..d65b5012a702
--- /dev/null
+++ b/x11-themes/gtk-engines/Manifest
@@ -0,0 +1 @@
+DIST gtk-engines-2.20.2.tar.bz2 688171 SHA256 15b680abca6c773ecb85253521fa100dd3b8549befeecc7595b10209d62d66b5 SHA512 049ae20d47a28b60fe5b0484e3c11bc6cd62d6167478f1d83df3066d618827ca9204767ab1b7a9ca02f542c3fc7929efc1bb85f65d66aaf5d5b15718b6de19e9 WHIRLPOOL eb28d402872dd8f553d15641e85dedb7e4b32bb4094fecd7213e12cb74d2fcf992220c5289f7d34ac20e7d4f0a6ba809dcb17130ee93aa3a2671c87110d5bd1b
diff --git a/x11-themes/gtk-engines/files/gtk-engines-2.20.2-glib.h.patch b/x11-themes/gtk-engines/files/gtk-engines-2.20.2-glib.h.patch
new file mode 100644
index 000000000000..35e5007e2c4a
--- /dev/null
+++ b/x11-themes/gtk-engines/files/gtk-engines-2.20.2-glib.h.patch
@@ -0,0 +1,26 @@
+From 8d49a386f467cbf8e0842d2218126f643e50f834 Mon Sep 17 00:00:00 2001
+From: Dominique Leuenberger <dimstar@opensuse.org>
+Date: Sun, 27 Nov 2011 15:24:57 +0100
+Subject: [PATCH] Fix build with glib 2.31: Only glib.h can be #include'd.
+ Fixes bug #664914
+
+---
+ engines/clearlooks/src/animation.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/engines/clearlooks/src/animation.c b/engines/clearlooks/src/animation.c
+index 1f7a41f..56a9286 100644
+--- a/engines/clearlooks/src/animation.c
++++ b/engines/clearlooks/src/animation.c
+@@ -28,7 +28,7 @@
+ #include "animation.h"
+
+ #ifdef HAVE_WORKING_ANIMATION
+-#include <glib/gtimer.h>
++#include <glib.h>
+
+ struct _AnimationInfo {
+ GTimer *timer;
+--
+1.7.8.5
+
diff --git a/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild b/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild
new file mode 100644
index 000000000000..a4e80a6ac5f2
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.20.2-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="accessibility lua"
+
+RDEPEND=">=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ lua? ( dev-lang/lua[${MULTILIB_USEDEP}] )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+GNOME2_LA_PUNT="yes"
+
+src_prepare() {
+ # Patch from 2.21.x, fixes building with glib-2.32, bug #410455
+ epatch "${FILESDIR}/${P}-glib.h.patch"
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ --enable-animation \
+ $(use_enable lua) \
+ $(use_with lua system-lua) \
+ $(use_enable accessibility hc)
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ local DOCS=( AUTHORS ChangeLog NEWS README )
+ einstalldocs
+}
diff --git a/x11-themes/gtk-engines/metadata.xml b/x11-themes/gtk-engines/metadata.xml
new file mode 100644
index 000000000000..1131e5f9b28a
--- /dev/null
+++ b/x11-themes/gtk-engines/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <longdescription>
+ This package contains some standard themes and theme engines for
+ GTK+. Version 0.12 provides engines and themes for GTK+ 1,
+ including Pixmap, Metal, Redmond95, Notif and Raleigh. Versions
+ 2.x provide engines and themes for GTK+ 2, including Clearlooks,
+ Crux, HighContrast, Industrial, Lighthouseblue, Metal, Mist,
+ Redmond, Smooth and Thinice.
+ </longdescription>
+</pkgmetadata>