summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-12-03 13:30:54 +0000
committerDan Armak <danarmak@gentoo.org>2002-12-03 13:30:54 +0000
commit0fd6db8a1c0cf38307f5a5f8bb5f6ff42cb08dab (patch)
tree8ff3c9f95a8fcd3ce202205c3308bc7213f9888d
parentmask new sys-apps/utempter (diff)
downloadhistorical-0fd6db8a1c0cf38307f5a5f8bb5f6ff42cb08dab.tar.gz
historical-0fd6db8a1c0cf38307f5a5f8bb5f6ff42cb08dab.tar.bz2
historical-0fd6db8a1c0cf38307f5a5f8bb5f6ff42cb08dab.zip
utempter: a daemon that grants safe root access to unprivileged programs. used by kdebase/konsole to write login information. masked and in testing.
-rw-r--r--sys-apps/utempter/ChangeLog11
-rw-r--r--sys-apps/utempter/files/digest-utempter-0.5.21
-rw-r--r--sys-apps/utempter/utempter-0.5.2.ebuild25
3 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/utempter/ChangeLog b/sys-apps/utempter/ChangeLog
new file mode 100644
index 000000000000..ebdeabc6875d
--- /dev/null
+++ b/sys-apps/utempter/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-apps/utempter
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/ChangeLog,v 1.1 2002/12/03 13:30:54 danarmak Exp $
+
+*utempter-0.5.2 (03 Dec 2002)
+
+ 03 Dec 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Utempter is a utility which allows some non-privileged programs to have
+ required root access without compromising system security. Utempter
+ accomplishes this feat by acting as a buffer between root and the programs.
diff --git a/sys-apps/utempter/files/digest-utempter-0.5.2 b/sys-apps/utempter/files/digest-utempter-0.5.2
new file mode 100644
index 000000000000..4dfc43b60a53
--- /dev/null
+++ b/sys-apps/utempter/files/digest-utempter-0.5.2
@@ -0,0 +1 @@
+MD5 7945baa995e1dbc0b6bc3d8c0487214b utempter-0.5.2.tar.gz 12574
diff --git a/sys-apps/utempter/utempter-0.5.2.ebuild b/sys-apps/utempter/utempter-0.5.2.ebuild
new file mode 100644
index 000000000000..b6b2abf50a8e
--- /dev/null
+++ b/sys-apps/utempter/utempter-0.5.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/utempter/utempter-0.5.2.ebuild,v 1.1 2002/12/03 13:30:54 danarmak Exp $
+
+DESCRIPTION="Daemon that allows non-privileged apps to have root access without compromising security"
+HOMEPAGE="www.redhat.com" # no homepage really, but redhat are the authors
+SRC_URI="mirror://gentoo/$P.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="virtual/glibc"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ export RPM_OPT_FLAGS="$CFLAGS"
+ make || die
+}
+
+src_install() {
+ make RPM_BUILD_ROOT="$D" install
+ dobin utmp
+ dodoc COPYING
+}