summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-08-17 14:40:15 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-08-17 14:40:15 +0000
commit1e1194a18a39347fa3fffca77a95103a8850af83 (patch)
treeaedd598597cdc6a8f9dfe8eb431ce4f1c025fce0
parentVersion bumped. (diff)
downloadhistorical-1e1194a18a39347fa3fffca77a95103a8850af83.tar.gz
historical-1e1194a18a39347fa3fffca77a95103a8850af83.tar.bz2
historical-1e1194a18a39347fa3fffca77a95103a8850af83.zip
Version bumped.
-rw-r--r--media-video/avifile/Manifest4
-rw-r--r--media-video/avifile/avifile-0.7.38.20030710.ebuild160
-rw-r--r--media-video/avifile/files/digest-avifile-0.7.38.200307101
3 files changed, 163 insertions, 2 deletions
diff --git a/media-video/avifile/Manifest b/media-video/avifile/Manifest
index 0ef32f305ee3..26d2ce4dd4e1 100644
--- a/media-video/avifile/Manifest
+++ b/media-video/avifile/Manifest
@@ -1,5 +1,5 @@
-MD5 9a956ea481529d189197209674501208 ChangeLog 9849
-MD5 a862cfaf41f9e57b141bb5c9382f389d avifile-0.7.38.20030710.ebuild 4472
+MD5 9c295c74000abcf7ff403b46eece9193 ChangeLog 9994
+MD5 bad3a8230974fae1f52a66af1b5319f7 avifile-0.7.38.20030710.ebuild 4182
MD5 7272f32f06100ca91ce93d4cbdbf664c avifile-0.7.32.20030219.ebuild 4084
MD5 fcc6fd107817ac0f3fd29d48db36fddb avifile-0.7.37.20030522-r2.ebuild 4499
MD5 21e60c1838b04fa1990fe5538569ac4b files/digest-avifile-0.7.38.20030710 71
diff --git a/media-video/avifile/avifile-0.7.38.20030710.ebuild b/media-video/avifile/avifile-0.7.38.20030710.ebuild
new file mode 100644
index 000000000000..ee0ba87c8262
--- /dev/null
+++ b/media-video/avifile/avifile-0.7.38.20030710.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/avifile/avifile-0.7.38.20030710.ebuild,v 1.1 2003/08/17 14:40:03 mholzer Exp $
+
+MAJ_PV=${PV:0:3}
+MIN_PV=${PV:0:6}
+MY_P="${PN}-${MAJ_PV}-${MIN_PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Library for AVI-Files"
+HOMEPAGE="http://avifile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0.7"
+KEYWORDS="~x86 ~sparc"
+IUSE="static truetype xv sdl dvd mmx sse 3dnow zlib oggvorbis X qt alsa esd debug"
+
+DEPEND=">=media-libs/jpeg-6b
+ x86? ( >=media-libs/divx4linux-20030428
+ >=media-libs/win32codecs-0.90 )
+ >=media-video/ffmpeg-0.4
+ >=media-libs/xvid-0.9.0
+ >=media-sound/lame-3.90
+ >=media-libs/audiofile-0.2.3
+ >=sys-apps/sed-4
+ >=media-sound/mad-0.14.2b
+ truetype? ( >=media-libs/freetype-2.1 )
+ xv? ( >=x11-base/xfree-4.2.1 )
+ sdl? ( >=media-libs/libsdl-1.2.2 )
+ dvd? ( >=media-libs/a52dec-0.7 )
+ zlib? ( >=sys-libs/zlib-1.1.3 )
+ oggvorbis? ( >=media-libs/libvorbis-1.0 )
+ X? ( >=x11-base/xfree-4.2.0 virtual/xft )
+ qt? ( >=x11-libs/qt-3.0.3 )
+ alsa? ( >=media-libs/alsa-lib-0.9.0_rc2 )
+ esd? ( >=media-sound/esound-0.2.28 )"
+
+src_unpack() {
+ unpack ${A}
+ use qt || sed -i 's/qt[a-z]*//g' ${S}/samples/Makefile.am
+}
+
+src_compile() {
+ local myconf="--enable-oss"
+ local kdepre=""
+
+ use static \
+ && myconf="${myconf} --enable-static" \
+ || myconf="${myconf} --disable-static"
+
+ use truetype \
+ && myconf="${myconf} --enable-freetype2" \
+ || myconf="${myconf} --disable-freetype2"
+
+ use xv \
+ && myconf="${myconf} --enable-xv" \
+ || myconf="${myconf} --disable-xv"
+
+ if [ "$XINERAMA" = "NO" ]; then
+ myconf="${myconf} --disable-xinerama"
+ fi
+
+ if [ "$DPMS" = "NO" ]; then
+ myconf="${myconf} --disable-dpms"
+ fi
+
+ use sdl \
+ && myconf="${myconf} --enable-sdl" \
+ || myconf="${myconf} --disable-sdl --disable-sdltest"
+
+ if [ "$V4L" = "NO" ]; then
+ myconf="${myconf} --disable-v4l"
+ fi
+
+ if [ "$SUN" = "NO" ]; then
+ myconf="${myconf} --disable-sunaudio"
+ fi
+
+ use dvd \
+ && myconf="${myconf} --enable-a52 --enable-ffmpeg-a52" \
+ || myconf="${myconf} --disable-a52 --disable-ffmpeg-a52"
+
+ if [ "$SBLIVE" = "NO" ]; then
+ myconf="${myconf} --disable-ac3passthrough"
+ fi
+
+ use debug \
+ && myconf="${myconf} --enable-loader-out" \
+ || myconf="${myconf} --enable-quiet"
+
+ ( use mmx || use sse || use 3dnow ) && myconf="${myconf} --enable-x86opt"
+
+ use zlib \
+ && myconf="${myconf} --enable-libz" \
+ || myconf="${myconf} --disable-libz"
+
+ use oggvorbis \
+ && myconf="${myconf} --enable-vorbis" \
+ || myconf="${myconf} --disable-vorbis --disable-oggtest --disable-vorbistest"
+
+ if [ "$MGA" = "NO" ]; then
+ myconf="${myconf} --disable-mga"
+ fi
+
+ if [ "$DMALLOC" = "YES" ]; then
+ myconf="${myconf} --with-dmallocth"
+ fi
+
+ use X \
+ && myconf="${myconf} --with-x --enable-xft" \
+ || myconf="${myconf} --without-x --disable-xft"
+
+ use qt \
+ && myconf="${myconf} --with-qt-prefix=${QTDIR}" \
+ || myconf="${myconf} --without-qt"
+
+ # Rather not use custom ones here .. build should set as high as
+ # safe by itself.
+ unset CFLAGS CXXFLAGS LDFLAGS CC CXX
+
+ # Make sure we include freetype2 headers before freetype1 headers, else Xft2
+ # borks, bug #11941.
+ export C_INCLUDE_PATH="${C_INCLUDE_PATH}:/usr/include/freetype2"
+ export CPLUS_INCLUDE_PATH="${CPLUS_INCLUDE_PATH}:/usr/include/freetype2"
+
+ # Fix qt detection
+ cp configure configure.orig
+ sed -e "s:extern \"C\" void exit(int);:/* extern \"C\" void exit(int); */:" \
+ < configure.orig > configure
+
+ econf \
+ --enable-samples \
+ --disable-vidix \
+ --with-fpic \
+ --with-gnu-ld \
+ --enable-lame-bin \
+ ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/lib /usr/bin
+ use avi && dodir /usr/lib/win32
+
+ einstall || die
+
+ cd ${S}
+ dodoc COPYING README INSTALL
+ cd doc
+ dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
+ dodoc VIDEO-PERFORMANCE WARNINGS KNOWN_BUGS
+}
+
+pkg_postinst() {
+ einfo "In order to use certain video modes, you must be root"
+ einfo "chmod +s /usr/bin/aviplay to suid root"
+ einfo "As this is considered a security risk on multiuser"
+ einfo "systems, this is not done by default"
+}
diff --git a/media-video/avifile/files/digest-avifile-0.7.38.20030710 b/media-video/avifile/files/digest-avifile-0.7.38.20030710
new file mode 100644
index 000000000000..e51b0d7555f8
--- /dev/null
+++ b/media-video/avifile/files/digest-avifile-0.7.38.20030710
@@ -0,0 +1 @@
+MD5 db90c4bc0a8a8182b1ec084feca86bbb avifile-0.7-0.7.38.tar.gz 2888580