summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2003-03-27 18:47:08 +0000
committerDaniel Robbins <drobbins@gentoo.org>2003-03-27 18:47:08 +0000
commit253295402faa6705ba47cf6f4a1488c589bac60c (patch)
tree5b0040d9fc4426ef9c598c7bf860cdde6a440a4c
parentnew libxml2 for unstable x86 (diff)
downloadhistorical-253295402faa6705ba47cf6f4a1488c589bac60c.tar.gz
historical-253295402faa6705ba47cf6f4a1488c589bac60c.tar.bz2
historical-253295402faa6705ba47cf6f4a1488c589bac60c.zip
New libxslt bumped into unstable x86
-rw-r--r--dev-libs/libxslt/ChangeLog7
-rw-r--r--dev-libs/libxslt/files/digest-libxslt-1.0.281
-rw-r--r--dev-libs/libxslt/libxslt-1.0.28.ebuild45
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-libs/libxslt/ChangeLog b/dev-libs/libxslt/ChangeLog
index 149d4ea06314..46daa658de12 100644
--- a/dev-libs/libxslt/ChangeLog
+++ b/dev-libs/libxslt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libxslt
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.26 2003/03/19 19:38:40 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/ChangeLog,v 1.27 2003/03/27 18:47:08 drobbins Exp $
+
+*libxslt-1.0.28 (27 Mar 2003)
+
+ 27 Mar 2003; Daniel Robbins <drobbins@gentoo.org> libxslt-1.0.28.ebuild:
+ New libxslt bumped into unstable x86.
*libxslt-1.0.27 (03 Mar 2003)
diff --git a/dev-libs/libxslt/files/digest-libxslt-1.0.28 b/dev-libs/libxslt/files/digest-libxslt-1.0.28
new file mode 100644
index 000000000000..084ea7fbfc94
--- /dev/null
+++ b/dev-libs/libxslt/files/digest-libxslt-1.0.28
@@ -0,0 +1 @@
+MD5 90006069a3d1504c63b1c0dbb0d0b756 libxslt-1.0.28.tar.bz2 1568614
diff --git a/dev-libs/libxslt/libxslt-1.0.28.ebuild b/dev-libs/libxslt/libxslt-1.0.28.ebuild
new file mode 100644
index 000000000000..6815ba6a43f1
--- /dev/null
+++ b/dev-libs/libxslt/libxslt-1.0.28.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.0.28.ebuild,v 1.1 2003/03/27 18:47:08 drobbins Exp $
+
+inherit libtool gnome.org
+
+IUSE="python"
+S=${WORKDIR}/${P}
+DESCRIPTION="XSLT libraries and tools"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~x86"
+
+RDEPEND=">=dev-libs/libxml2-2.5.5 python? ( dev-lang/python )"
+
+DEPEND="${RDEPEND} dev-lang/perl"
+
+src_compile() {
+ # Fix .la files of python site packages
+ elibtoolize
+
+ local myconf
+
+ use python && myconf="--with-python" || myconf="--without-python"
+
+ econf ${myconf} || die
+
+ #libxslt-1.0.19 didn't like parallel make; test a good deal before re-enabling
+ #(drobbins, 24 Jul 2002)
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} \
+ DOCS_DIR=/usr/share/doc/${PF}/python \
+ EXAMPLE_DIR=/usr/share/doc/${PF}/python/example \
+ BASE_DIR=/usr/share/doc \
+ DOC_MODULE=${PF} \
+ EXAMPLES_DIR=/usr/share/doc/${PF}/example \
+ TARGET_DIR=/usr/share/doc/${PF}/html \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README NEWS TODO
+}