summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2005-12-05 03:35:03 +0000
committerJoshua Nichols <nichoj@gentoo.org>2005-12-05 03:35:03 +0000
commit54c9e3d82569f629b0e09b1c3c884fb4909aa463 (patch)
tree111bbcd17cbe185115015c7dd22b276b7e56769e
parentInitial commit - bug #98781, based on ebuild submitted by Dick Marinus <dm@ch... (diff)
downloadhistorical-54c9e3d82569f629b0e09b1c3c884fb4909aa463.tar.gz
historical-54c9e3d82569f629b0e09b1c3c884fb4909aa463.tar.bz2
historical-54c9e3d82569f629b0e09b1c3c884fb4909aa463.zip
Initial commit (bug #97008).
Package-Manager: portage-2.0.53_rc7
-rw-r--r--dev-java/commons-attributes/ChangeLog11
-rw-r--r--dev-java/commons-attributes/Manifest16
-rw-r--r--dev-java/commons-attributes/commons-attributes-2.1.ebuild58
-rw-r--r--dev-java/commons-attributes/files/anttasks.properties18
-rw-r--r--dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch32
-rw-r--r--dev-java/commons-attributes/files/digest-commons-attributes-2.11
-rw-r--r--dev-java/commons-attributes/metadata.xml5
7 files changed, 141 insertions, 0 deletions
diff --git a/dev-java/commons-attributes/ChangeLog b/dev-java/commons-attributes/ChangeLog
new file mode 100644
index 000000000000..616ff5bd5fcf
--- /dev/null
+++ b/dev-java/commons-attributes/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-java/commons-attributes
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/ChangeLog,v 1.1 2005/12/05 03:35:03 nichoj Exp $
+
+*commons-attributes-2.1 (05 Dec 2005)
+
+ 05 Dec 2005; Joshua Nichols <nichoj@gentoo.org>
+ +files/commons-attributes-2.1-gentoo.patch, +files/anttasks.properties,
+ +metadata.xml, +commons-attributes-2.1.ebuild:
+ Initial commit (bug #97008).
+
diff --git a/dev-java/commons-attributes/Manifest b/dev-java/commons-attributes/Manifest
new file mode 100644
index 000000000000..eb900f5bf629
--- /dev/null
+++ b/dev-java/commons-attributes/Manifest
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 fb9be42044924f2208bc33ed64d34475 ChangeLog 471
+MD5 556c76a3982d832711f40daa0c798a5c commons-attributes-2.1.ebuild 1626
+MD5 afa7033a8f1ac9174d37628b7734a1f8 files/anttasks.properties 856
+MD5 95c743163c69489b7e543bd18593ce3c files/commons-attributes-2.1-gentoo.patch 1651
+MD5 02d5609bcdd04538df28834127b4bf8d files/digest-commons-attributes-2.1 74
+MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2 (GNU/Linux)
+
+iD8DBQFDk7V8ndWRXhKOboURAiELAJ9bSLTQNGYrhZZk4H/N6sCmt3VDyACg0hbU
+RM8A5UZJufbH6tRmRv5auxY=
+=cMxt
+-----END PGP SIGNATURE-----
diff --git a/dev-java/commons-attributes/commons-attributes-2.1.ebuild b/dev-java/commons-attributes/commons-attributes-2.1.ebuild
new file mode 100644
index 000000000000..1b6c88d41ec3
--- /dev/null
+++ b/dev-java/commons-attributes/commons-attributes-2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-attributes/commons-attributes-2.1.ebuild,v 1.1 2005/12/05 03:35:03 nichoj Exp $
+
+inherit eutils java-pkg
+
+DESCRIPTION="Commons Attributes enables Java programmers to use C#/.Net-style attributes in their code."
+HOMEPAGE="http://jakarta.apache.org/commons/attributes/"
+SRC_URI="mirror://apache/jakarta/commons/attributes/source/${P}-src.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc jikes source"
+
+# TODO determine jvm version requirements
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core
+ jikes? (dev-java/jikes)
+ dev-java/xjavadoc"
+RDEPEND=">=virtual/jre-1.4
+ dev-java/xjavadoc"
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ mkdir -p target/classes/org/apache/commons/attributes
+ # This file is missing from upstream's release
+ # and is needed to use the ant task.
+ cp ${FILESDIR}/anttasks.properties target/classes/org/apache/commons/attributes/
+
+ mkdir -p target/lib
+ cd target/lib
+ java-pkg_jar-from xjavadoc
+}
+
+src_compile() {
+ local antflags="jar -Dnoget=true"
+ use jikes && antflags="-Dbuild.compiler=jikes ${antflags}"
+ use doc && antflags="${antflags} javadoc"
+
+ ant ${antflags} || die "Compilation failed"
+}
+
+src_install() {
+ java-pkg_newjar target/${PN}-api-${PV}.jar ${PN}-api.jar
+ java-pkg_newjar target/${PN}-compiler-${PV}.jar ${PN}-compiler.jar
+
+ dodoc NOTICE.txt RELEASE.txt
+ dohtml README.html
+
+ use doc && java-pkg_dohtml -r dist/docs/api
+ use source && java-pkg_dosrc */src/java/*
+}
diff --git a/dev-java/commons-attributes/files/anttasks.properties b/dev-java/commons-attributes/files/anttasks.properties
new file mode 100644
index 000000000000..271c87b9240d
--- /dev/null
+++ b/dev-java/commons-attributes/files/anttasks.properties
@@ -0,0 +1,18 @@
+#
+# Copyright 2003-2004 The Apache Software Foundation
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+attribute-compiler=org.apache.commons.attributes.compiler.AttributeCompiler
+attribute-indexer=org.apache.commons.attributes.compiler.AttributeIndexer
+attribute-validator=org.apache.commons.attributes.validation.AttributeValidatorTask \ No newline at end of file
diff --git a/dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch b/dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch
new file mode 100644
index 000000000000..b4de400cb3a1
--- /dev/null
+++ b/dev-java/commons-attributes/files/commons-attributes-2.1-gentoo.patch
@@ -0,0 +1,32 @@
+Only in commons-attributes-patched/: .build.xml.swo
+Only in commons-attributes-patched/: .build.xml.swp
+diff -ru commons-attributes/build.xml commons-attributes-patched/build.xml
+--- commons-attributes/build.xml 2004-08-01 16:18:27.000000000 -0400
++++ commons-attributes-patched/build.xml 2005-06-24 21:31:02.000000000 -0400
+@@ -86,6 +86,9 @@
+ <include name="**/*.xservice">
+ </include>
+ </fileset>
++ <fileset dir="compiler/src/java">
++ <include name="org/apache/commons/attributes/anttasks.properties"/>
++ </fileset>
+ </copy>
+ <copy todir="${classesdir}">
+ <fileset dir="." includes="LICENSE.txt,NOTICE.txt"/>
+@@ -100,7 +103,7 @@
+ <target name="jar" description="o Create the jar" depends="compile">
+ <jar jarfile="target/${final.name.api}.jar" includes="org/apache/commons/attributes/*,LICENSE.txt,NOTICE.txt" basedir="${classesdir}">
+ </jar>
+- <jar jarfile="target/${final.name.compiler}.jar" excludes="org/apache/commons/attributes/*" includes="**/*" basedir="${classesdir}">
++ <jar jarfile="target/${final.name.compiler}.jar" excludes="org/apache/commons/attributes/*.class" includes="**/*,org/apache/commons/attributes/anttasks.properties" basedir="${classesdir}">
+ </jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+@@ -162,4 +167,4 @@
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
+ </unjar>
+ </target>
+-</project>
+\ No newline at end of file
++</project>
+Only in commons-attributes-patched/: target
diff --git a/dev-java/commons-attributes/files/digest-commons-attributes-2.1 b/dev-java/commons-attributes/files/digest-commons-attributes-2.1
new file mode 100644
index 000000000000..a65504200934
--- /dev/null
+++ b/dev-java/commons-attributes/files/digest-commons-attributes-2.1
@@ -0,0 +1 @@
+MD5 3ee125a9f06ae3462f1d5ac58f7c1648 commons-attributes-2.1-src.tgz 89259
diff --git a/dev-java/commons-attributes/metadata.xml b/dev-java/commons-attributes/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-attributes/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>