summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-05-03 17:49:12 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-05-03 17:49:12 +0000
commit799e5e9be42413453fb5e310bd11f32142df8c12 (patch)
tree7ebc99a0bed17ca09a36118c0c2638867b1c0d16
parentRemove old (diff)
downloadhistorical-799e5e9be42413453fb5e310bd11f32142df8c12.tar.gz
historical-799e5e9be42413453fb5e310bd11f32142df8c12.tar.bz2
historical-799e5e9be42413453fb5e310bd11f32142df8c12.zip
Bump to 1.4.44
Package-Manager: portage-2.2_rc67/cvs/Linux x86_64
-rw-r--r--dev-db/tokyocabinet/ChangeLog8
-rw-r--r--dev-db/tokyocabinet/files/1.4.44.patch12
-rw-r--r--dev-db/tokyocabinet/tokyocabinet-1.4.44.ebuild45
3 files changed, 64 insertions, 1 deletions
diff --git a/dev-db/tokyocabinet/ChangeLog b/dev-db/tokyocabinet/ChangeLog
index 711ae0b783b9..d4cdb3950e0a 100644
--- a/dev-db/tokyocabinet/ChangeLog
+++ b/dev-db/tokyocabinet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tokyocabinet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.22 2010/03/17 21:25:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/ChangeLog,v 1.23 2010/05/03 17:49:12 patrick Exp $
+
+*tokyocabinet-1.4.44 (03 May 2010)
+
+ 03 May 2010; Patrick Lauer <patrick@gentoo.org> +files/1.4.44.patch,
+ +tokyocabinet-1.4.44.ebuild:
+ Bump to 1.4.44
*tokyocabinet-1.4.43 (17 Mar 2010)
diff --git a/dev-db/tokyocabinet/files/1.4.44.patch b/dev-db/tokyocabinet/files/1.4.44.patch
new file mode 100644
index 000000000000..1e5ccca83bd0
--- /dev/null
+++ b/dev-db/tokyocabinet/files/1.4.44.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.in b/Makefile.in
+index 973bf81..e44f0a8 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -125,7 +125,6 @@ install :
+ cd man && cp -Rf $(MAN3FILES) $(DESTDIR)$(MAN3DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- [ "$$UID" = 0 ] && ldconfig || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Tokyo Cabinet.\n'
diff --git a/dev-db/tokyocabinet/tokyocabinet-1.4.44.ebuild b/dev-db/tokyocabinet/tokyocabinet-1.4.44.ebuild
new file mode 100644
index 000000000000..cbf491480120
--- /dev/null
+++ b/dev-db/tokyocabinet/tokyocabinet-1.4.44.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tokyocabinet/tokyocabinet-1.4.44.ebuild,v 1.1 2010/05/03 17:49:12 patrick Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A library of routines for managing a database"
+HOMEPAGE="http://1978th.net/tokyocabinet/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/zlib
+ app-arch/bzip2"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/fix_rpath.patch"
+ epatch "${FILESDIR}/${PV}.patch"
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+
+ if use examples; then
+ dodoc example/* || die "Install failed"
+ fi
+
+ if use doc; then
+ dodoc doc/* || die "Install failed"
+ fi
+}
+
+src_test() {
+ emake -j1 check || die "Tests failed"
+}