summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-30 13:43:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-09-30 13:43:19 +0000
commit7cda95307f5f86a8e1a13ce0c13797ed75d997af (patch)
tree8b751279561bad88b693200f3ef63eed568d631d
parentVersion bump. (diff)
downloadhistorical-7cda95307f5f86a8e1a13ce0c13797ed75d997af.tar.gz
historical-7cda95307f5f86a8e1a13ce0c13797ed75d997af.tar.bz2
historical-7cda95307f5f86a8e1a13ce0c13797ed75d997af.zip
Version bump.
Package-Manager: portage-2.1.2_pre2
-rw-r--r--media-sound/alsa-driver/ChangeLog8
-rw-r--r--media-sound/alsa-driver/alsa-driver-1.0.13.ebuild179
-rw-r--r--media-sound/alsa-driver/files/digest-alsa-driver-1.0.133
-rw-r--r--media-sound/alsa-firmware/ChangeLog8
-rw-r--r--media-sound/alsa-firmware/alsa-firmware-1.0.13.ebuild31
-rw-r--r--media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.133
-rw-r--r--media-sound/alsa-headers/ChangeLog8
-rw-r--r--media-sound/alsa-headers/alsa-headers-1.0.13.ebuild44
-rw-r--r--media-sound/alsa-headers/files/digest-alsa-headers-1.0.133
-rw-r--r--media-sound/alsa-tools/ChangeLog8
-rw-r--r--media-sound/alsa-tools/alsa-tools-1.0.13.ebuild111
-rw-r--r--media-sound/alsa-tools/files/digest-alsa-tools-1.0.133
-rw-r--r--media-sound/alsa-utils/ChangeLog8
-rw-r--r--media-sound/alsa-utils/alsa-utils-1.0.13.ebuild84
-rw-r--r--media-sound/alsa-utils/files/digest-alsa-utils-1.0.133
15 files changed, 499 insertions, 5 deletions
diff --git a/media-sound/alsa-driver/ChangeLog b/media-sound/alsa-driver/ChangeLog
index 4db611925d8d..b5c01eb58465 100644
--- a/media-sound/alsa-driver/ChangeLog
+++ b/media-sound/alsa-driver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-driver
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.225 2006/09/28 06:58:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/ChangeLog,v 1.226 2006/09/30 13:43:19 flameeyes Exp $
+
+*alsa-driver-1.0.13 (30 Sep 2006)
+
+ 30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-driver-1.0.13.ebuild:
+ Version bump.
*alsa-driver-1.0.13_rc3 (28 Sep 2006)
diff --git a/media-sound/alsa-driver/alsa-driver-1.0.13.ebuild b/media-sound/alsa-driver/alsa-driver-1.0.13.ebuild
new file mode 100644
index 000000000000..50c6b0caebda
--- /dev/null
+++ b/media-sound/alsa-driver/alsa-driver-1.0.13.ebuild
@@ -0,0 +1,179 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-driver/alsa-driver-1.0.13.ebuild,v 1.1 2006/09/30 13:43:19 flameeyes Exp $
+
+inherit linux-mod flag-o-matic eutils multilib
+
+MY_P="${P/_rc/rc}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="oss doc debug"
+
+RDEPEND="virtual/modutils
+ ~media-sound/alsa-headers-${PV}
+ !media-sound/snd-aoa"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ sparc? ( >=sys-devel/autoconf-2.50 )
+ sys-apps/debianutils"
+
+PROVIDE="virtual/alsa"
+
+pkg_setup() {
+ # By default, drivers for all supported cards will be compiled.
+ # If you want to only compile for specific card(s), set ALSA_CARDS
+ # environment to a space-separated list of drivers that you want to build.
+ # For example:
+ #
+ # env ALSA_CARDS='emu10k1 intel8x0 ens1370' emerge alsa-driver
+ #
+ ALSA_CARDS=${ALSA_CARDS:-all}
+
+ # Which drivers need PNP
+ local PNP_DRIVERS="interwave interwave-stb"
+
+ CONFIG_CHECK="SOUND"
+ SND_ERROR="ALSA is already compiled into the kernel."
+ SOUND_ERROR="Your kernel doesn't have sound support enabled."
+ SOUND_PRIME_ERROR="Your kernel is configured to use the deprecated OSS drivers. Please disable them and re-emerge alsa-driver."
+ PNP_ERROR="Some of the drivers you selected require PNP in your kernel (${PNP_DRIVERS}). Either enable PNP in your kernel or trim which drivers get compiled using ALSA_CARDS in /etc/make.conf."
+
+ if [[ "${ALSA_CARDS}" == "all" ]]; then
+
+ # Ignore PNP checks for ppc architecture, as PNP can't be enabled there.
+ if [[ ${ARCH} != "ppc" ]]; then
+ CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ fi
+ else
+ for pnpdriver in ${PNP_DRIVERS}; do
+ hasq ${pnpdriver} ${ALSA_CARDS} && CONFIG_CHECK="${CONFIG_CHECK} PNP"
+ done
+ fi
+
+ linux-mod_pkg_setup
+
+ if [[ ${PROFILE_ARCH} == "sparc64" ]] ; then
+ export CBUILD=${CBUILD-${CHOST}}
+ export CHOST="sparc64-unknown-linux-gnu"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.10_rc1-include.patch"
+
+ epatch "${FILESDIR}/${PN}-mcp55.patch"
+
+ if kernel_is ge 2 6 17 ; then
+ # These are needed for some drivers to build with kernel 2.6.17
+ # until a refreshed release of alsa-driver is done
+ epatch "${FILESDIR}/${PN}-1.0.11-kernel-2.6.17.patch"
+
+ # asihpi driver is broken, skip it until upstream releases something
+ # working.
+ sed -i -e 's:asihpi/::' "${S}/pci/Makefile"
+ fi
+
+ convert_to_m "${S}/Makefile"
+ sed -i -e 's:\(.*depmod\):#\1:' "${S}/Makefile"
+}
+
+src_compile() {
+ local myABI=${ABI:-${DEFAULT_ABI}}
+
+ # Should fix bug #46901
+ is-flag "-malign-double" && filter-flags "-fomit-frame-pointer"
+ append-flags "-I${KV_DIR}/arch/$(tc-arch-kernel)/include"
+
+ econf $(use_with oss) \
+ $(use_with debug debug full) \
+ --with-kernel="${KV_DIR}" \
+ --with-build="${KV_OUT_DIR}" \
+ --with-isapnp=yes \
+ --with-sequencer=yes \
+ --with-cards="${ALSA_CARDS}" || die "econf failed"
+
+ # linux-mod_src_compile doesn't work well with alsa
+
+ ARCH=$(tc-arch-kernel)
+ ABI=${KERNEL_ABI}
+ emake LDFLAGS="$(raw-ldflags)" HOSTCC=$(tc-getBUILD_CC) CC=$(tc-getCC) || die "Make Failed"
+ ARCH=$(tc-arch)
+ ABI=${myABI}
+
+ if use doc;
+ then
+ ebegin "Building Documentation"
+ cd ${S}/scripts
+ emake || die Failed making docs in ${S}/scripts
+
+ cd ${S}/doc/DocBook
+ emake || die Failed making docs in ${S}/doc/DocBook
+ eend $?
+ fi
+}
+
+
+src_install() {
+ emake DESTDIR=${D} install-modules || die "make install failed"
+
+ dodoc CARDS-STATUS FAQ README WARNING TODO
+
+ if use doc; then
+ docinto doc
+ dodoc doc/*
+ rm ${D}/usr/share/doc/${PF}/doc/Makefile.gz
+
+ docinto DocBook
+ dodoc doc/DocBook/*
+ rm ${D}/usr/share/doc/${PF}/DocBook/Makefile.gz
+
+ docinto Documentation
+ dodoc sound/Documentation/*
+ fi
+
+ if kernel_is 2 6; then
+ # mv the drivers somewhere they won't be killed by the kernel's make modules_install
+ mv ${D}/lib/modules/${KV_FULL}/kernel/sound ${D}/lib/modules/${KV_FULL}/${PN}
+ rmdir ${D}/lib/modules/${KV_FULL}/kernel &> /dev/null
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The alsasound initscript and modules.d/alsa have now moved to alsa-utils"
+ einfo
+ einfo "Also, remember that all mixer channels will be MUTED by default."
+ einfo "Use the 'alsamixer' program to unmute them."
+ einfo
+ einfo "Version 1.0.3 and above should work with version 2.6 kernels."
+ einfo "If you experience problems, please report bugs to http://bugs.gentoo.org."
+ einfo
+
+ linux-mod_pkg_postinst
+
+ einfo "Check out the ALSA installation guide availible at the following URL:"
+ einfo "http://www.gentoo.org/doc/en/alsa-guide.xml"
+
+ if kernel_is 2 6 && [ -e ${ROOT}/lib/modules/${KV_FULL}/kernel/sound ]; then
+ # Cleanup if they had older alsa installed
+ for file in $(find ${ROOT}/lib/modules/${KV_FULL}/${PN} -type f); do
+ rm -f ${file//${KV_FULL}\/${PN}/${KV_FULL}\/kernel\/sound}
+ done
+
+ for dir in $(find ${ROOT}/lib/modules/${KV_FULL}/kernel/sound -type d | tac); do
+ rmdir ${dir} &> /dev/null
+ done
+ fi
+}
diff --git a/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13 b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13
new file mode 100644
index 000000000000..a218a9b0631b
--- /dev/null
+++ b/media-sound/alsa-driver/files/digest-alsa-driver-1.0.13
@@ -0,0 +1,3 @@
+MD5 3fe79d8fd475a442b59d4716f7bb20a5 alsa-driver-1.0.13.tar.bz2 2404965
+RMD160 cf17c49563321620c7c1037f6087c85b69278b12 alsa-driver-1.0.13.tar.bz2 2404965
+SHA256 91c37a7e2575cb44bc53cf9c13e2049db73d257242e4d6ab55150a0f704b84d3 alsa-driver-1.0.13.tar.bz2 2404965
diff --git a/media-sound/alsa-firmware/ChangeLog b/media-sound/alsa-firmware/ChangeLog
index 32a2bf976b11..e8bb73df9709 100644
--- a/media-sound/alsa-firmware/ChangeLog
+++ b/media-sound/alsa-firmware/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-firmware
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-firmware/ChangeLog,v 1.32 2006/09/16 12:14:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-firmware/ChangeLog,v 1.33 2006/09/30 13:42:30 flameeyes Exp $
+
+*alsa-firmware-1.0.13 (30 Sep 2006)
+
+ 30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-firmware-1.0.13.ebuild:
+ Version bump.
*alsa-firmware-1.0.13_rc2 (16 Sep 2006)
diff --git a/media-sound/alsa-firmware/alsa-firmware-1.0.13.ebuild b/media-sound/alsa-firmware/alsa-firmware-1.0.13.ebuild
new file mode 100644
index 000000000000..a39a51b8d8d7
--- /dev/null
+++ b/media-sound/alsa-firmware/alsa-firmware-1.0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-firmware/alsa-firmware-1.0.13.ebuild,v 1.1 2006/09/30 13:42:30 flameeyes Exp $
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture firmware"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/firmware/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+DEPEND=""
+
+src_compile() {
+ econf \
+ --with-hotplug-dir=/lib/firmware \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README
+}
diff --git a/media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.13 b/media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.13
new file mode 100644
index 000000000000..b144d2582481
--- /dev/null
+++ b/media-sound/alsa-firmware/files/digest-alsa-firmware-1.0.13
@@ -0,0 +1,3 @@
+MD5 97de41a923e68c3d6c52c14f1a2843df alsa-firmware-1.0.13.tar.bz2 2842664
+RMD160 58354210d79e5c3a137d066d9d2278c6cfd0c492 alsa-firmware-1.0.13.tar.bz2 2842664
+SHA256 28a704759a5f7bc4692cbff6988bb85c5d5cd6cf84d0d39208af65441c0d57bb alsa-firmware-1.0.13.tar.bz2 2842664
diff --git a/media-sound/alsa-headers/ChangeLog b/media-sound/alsa-headers/ChangeLog
index b6afbd5196ad..debe6d1680c9 100644
--- a/media-sound/alsa-headers/ChangeLog
+++ b/media-sound/alsa-headers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-headers
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.86 2006/09/28 06:56:55 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/ChangeLog,v 1.87 2006/09/30 13:43:08 flameeyes Exp $
+
+*alsa-headers-1.0.13 (30 Sep 2006)
+
+ 30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-headers-1.0.13.ebuild:
+ Version bump.
*alsa-headers-1.0.13_rc3 (28 Sep 2006)
diff --git a/media-sound/alsa-headers/alsa-headers-1.0.13.ebuild b/media-sound/alsa-headers/alsa-headers-1.0.13.ebuild
new file mode 100644
index 000000000000..086cd4569b92
--- /dev/null
+++ b/media-sound/alsa-headers/alsa-headers-1.0.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-headers/alsa-headers-1.0.13.ebuild,v 1.1 2006/09/30 13:43:08 flameeyes Exp $
+
+inherit eutils
+
+MY_PN=${PN/headers/driver}
+MY_P="${MY_PN}-${PV/_rc/rc}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Header files for Advanced Linux Sound Architecture kernel modules"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/driver/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+# Remove the sound symlink workaround...
+pkg_setup() {
+ if [[ -L "${ROOT}/usr/include/sound" ]]; then
+ rm "${ROOT}/usr/include/sound"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.0.6a-user.patch"
+}
+
+src_compile() {
+ einfo "No compilation neccessary"
+}
+
+src_install() {
+ cd "${S}/alsa-kernel/include"
+ insinto /usr/include/sound
+ doins *.h || die "include failed"
+}
diff --git a/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13 b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13
new file mode 100644
index 000000000000..a218a9b0631b
--- /dev/null
+++ b/media-sound/alsa-headers/files/digest-alsa-headers-1.0.13
@@ -0,0 +1,3 @@
+MD5 3fe79d8fd475a442b59d4716f7bb20a5 alsa-driver-1.0.13.tar.bz2 2404965
+RMD160 cf17c49563321620c7c1037f6087c85b69278b12 alsa-driver-1.0.13.tar.bz2 2404965
+SHA256 91c37a7e2575cb44bc53cf9c13e2049db73d257242e4d6ab55150a0f704b84d3 alsa-driver-1.0.13.tar.bz2 2404965
diff --git a/media-sound/alsa-tools/ChangeLog b/media-sound/alsa-tools/ChangeLog
index 2415a64f53b0..37f344988a4e 100644
--- a/media-sound/alsa-tools/ChangeLog
+++ b/media-sound/alsa-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-tools
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.111 2006/09/16 12:14:32 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/ChangeLog,v 1.112 2006/09/30 13:43:07 flameeyes Exp $
+
+*alsa-tools-1.0.13 (30 Sep 2006)
+
+ 30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-tools-1.0.13.ebuild:
+ Version bump.
*alsa-tools-1.0.13_rc2 (16 Sep 2006)
diff --git a/media-sound/alsa-tools/alsa-tools-1.0.13.ebuild b/media-sound/alsa-tools/alsa-tools-1.0.13.ebuild
new file mode 100644
index 000000000000..829d11df1423
--- /dev/null
+++ b/media-sound/alsa-tools/alsa-tools-1.0.13.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-1.0.13.ebuild,v 1.1 2006/09/30 13:43:07 flameeyes Exp $
+
+inherit eutils flag-o-matic autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture tools"
+HOMEPAGE="http://www.alsa-project.org"
+SRC_URI="mirror://alsaproject/tools/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="fltk gtk"
+
+RDEPEND=">=media-libs/alsa-lib-1.0.0
+ virtual/alsa
+ fltk? ( =x11-libs/fltk-1.1* )
+ gtk? ( =x11-libs/gtk+-2* )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ # This is a list of the tools in the package.
+ # Some of the tools don't make proper use of CFLAGS, even though
+ # all of them seem to use autoconf. This needs to be fixed.
+ #
+ # By default, all the supported tools will be compiled.
+ # If you want to only compile for specific tool(s), set ALSA_TOOLS
+ # environment to a space-separated list of tools that you want to build.
+ # For example:
+ #
+ # env ALSA_TOOLS='as10k1 ac3dec' emerge alsa-tools
+ #
+ if [ -z "${ALSA_TOOLS}" ]; then
+ ALSA_TOOLS="ac3dec as10k1 hdsploader mixartloader seq/sbiload \
+ sscape_ctl us428control usx2yloader vxloader"
+
+ if use fltk; then
+ ALSA_TOOLS="${ALSA_TOOLS} hdspconf hdspmixer"
+ fi
+
+ if use gtk; then
+ ALSA_TOOLS="${ALSA_TOOLS} echomixer envy24control rmedigicontrol"
+ fi
+
+ # sb16_csp won't build on ppc64 _AND_ ppc (and is not needed)
+ if use !ppc64 && use !ppc; then
+ ALSA_TOOLS="${ALSA_TOOLS} sb16_csp"
+ fi
+
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11-asneeded.patch"
+
+ for dir in echomixer envy24control rmedigicontrol; do
+ pushd ${dir} &> /dev/null
+ eautomake
+ popd &> /dev/null
+ done
+
+ elibtoolize
+}
+
+src_compile() {
+ if use fltk; then
+ # hdspmixer requires fltk
+ append-ldflags "-L/usr/$(get_libdir)/fltk-1.1"
+ append-flags "-I/usr/include/fltk-1.1"
+ fi
+
+ # hdspmixer is missing depconf - copy from the hdsploader directory
+ cp ${S}/hdsploader/depcomp ${S}/hdspmixer/
+
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+ econf || die "econf failed"
+ make || die "make failed"
+ done
+}
+
+src_install() {
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ # Install the main stuff
+ cd "${S}/${f}"
+ emake DESTDIR="${D}" install || die
+
+ # Install the text documentation
+ local doc
+ for doc in README TODO ChangeLog AUTHORS
+ do
+ if [ -f "${doc}" ]
+ then
+ mv "${doc}" "${doc}.`basename ${f}`"
+ dodoc "${doc}.`basename ${f}`"
+ fi
+ done
+ done
+}
diff --git a/media-sound/alsa-tools/files/digest-alsa-tools-1.0.13 b/media-sound/alsa-tools/files/digest-alsa-tools-1.0.13
new file mode 100644
index 000000000000..4b89fa8ab5ee
--- /dev/null
+++ b/media-sound/alsa-tools/files/digest-alsa-tools-1.0.13
@@ -0,0 +1,3 @@
+MD5 3f30a884848a21910195a3c77f1dbde2 alsa-tools-1.0.13.tar.bz2 1464807
+RMD160 1e55ab98dcc78dabbfec8f057bb164482d334c9a alsa-tools-1.0.13.tar.bz2 1464807
+SHA256 1d82c6f64d035e20fb151b8791972cad47ef229bc365fd046ff64f74bec31eb3 alsa-tools-1.0.13.tar.bz2 1464807
diff --git a/media-sound/alsa-utils/ChangeLog b/media-sound/alsa-utils/ChangeLog
index 63b3dca97123..2e89dd0bb147 100644
--- a/media-sound/alsa-utils/ChangeLog
+++ b/media-sound/alsa-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/alsa-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.159 2006/09/28 06:57:12 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/ChangeLog,v 1.160 2006/09/30 13:43:06 flameeyes Exp $
+
+*alsa-utils-1.0.13 (30 Sep 2006)
+
+ 30 Sep 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +alsa-utils-1.0.13.ebuild:
+ Version bump.
*alsa-utils-1.0.13_rc3 (28 Sep 2006)
diff --git a/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild b/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild
new file mode 100644
index 000000000000..8cdc6931a8bc
--- /dev/null
+++ b/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-utils/alsa-utils-1.0.13.ebuild,v 1.1 2006/09/30 13:43:06 flameeyes Exp $
+
+inherit eutils autotools
+
+MY_P="${P/_rc/rc}"
+
+DESCRIPTION="Advanced Linux Sound Architecture Utils (alsactl, alsamixer, etc.)"
+HOMEPAGE="http://www.alsa-project.org/"
+SRC_URI="mirror://alsaproject/utils/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0.9"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="nls"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-util/dialog
+ >=media-libs/alsa-lib-1.0.12"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-1.0.11_rc2-nls.patch"
+ epatch "${FILESDIR}/${PN}-1.0.11_rc5-alsaconf-redirect.patch"
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ local ALSA_UTILS_DOCS="ChangeLog README TODO
+ seq/aconnect/README.aconnect
+ seq/aseqnet/README.aseqnet"
+
+ emake DESTDIR="${D}" install || die "Installation Failed"
+
+ dodoc ${ALSA_UTILS_DOCS}
+ newdoc alsamixer/README README.alsamixer
+
+ newconfd "${FILESDIR}/alsasound.confd" alsasound
+ insinto /etc/modules.d
+ newins "${FILESDIR}/alsa-modules.conf-rc" alsa
+ newinitd "${FILESDIR}/alsasound-1.0.10_rc2" alsasound
+}
+
+pkg_postinst() {
+ echo
+ einfo "The alsasound initscript is now provided by alsa-utils"
+ einfo "instead of alsa-driver for compatibility with kernel-sources"
+ einfo "which provide ALSA internally."
+ echo
+ einfo "To take advantage of this, and automate the process of"
+ einfo "loading and unloading the ALSA sound drivers as well as"
+ einfo "storing and restoring sound-card mixer levels you should"
+ einfo "add alsasound to the boot runlevel. You can do this as"
+ einfo "root like so:"
+ einfo " # rc-update add alsasound boot"
+ echo
+ einfo "You will also need to edit the file /etc/modules.d/alsa"
+ einfo "and run modules-update. You can do this like so:"
+ einfo " # nano -w /etc/modules.d/alsa && modules-update"
+ echo
+
+ if use sparc; then
+ ewarn "Old versions of alsa-drivers had a broken snd-ioctl32 module"
+ ewarn "which causes sparc64 machines to lockup on such tasks as"
+ ewarn "changing the volume. Because of this, it is VERY important"
+ ewarn "that you do not use the snd-ioctl32 modules contained in"
+ ewarn "development-sources or <=gentoo-dev-sources-2.6.7-r14. Doing so"
+ ewarn "may result in an unbootable system if you start alsasound at boot."
+ fi
+}
diff --git a/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13 b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13
new file mode 100644
index 000000000000..9000baa0be91
--- /dev/null
+++ b/media-sound/alsa-utils/files/digest-alsa-utils-1.0.13
@@ -0,0 +1,3 @@
+MD5 dfe4bb5d3217f3ec662b172ce8397cf0 alsa-utils-1.0.13.tar.bz2 980874
+RMD160 2a3cd882543232f81e211d216c9e8112da3f8977 alsa-utils-1.0.13.tar.bz2 980874
+SHA256 d7fe8a7995bc74331c89fbc1937a0682d239339d6659a402cd7b8e4b96c050f0 alsa-utils-1.0.13.tar.bz2 980874